summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/geos-3.5.0-r2.ebuild6
-rw-r--r--sci-libs/geos/geos-3.5.0.ebuild6
-rw-r--r--sci-libs/geos/geos-3.6.1.ebuild1
3 files changed, 9 insertions, 4 deletions
diff --git a/sci-libs/geos/geos-3.5.0-r2.ebuild b/sci-libs/geos/geos-3.5.0-r2.ebuild
index 7871f62022d8..986fa56bbe03 100644
--- a/sci-libs/geos/geos-3.5.0-r2.ebuild
+++ b/sci-libs/geos/geos-3.5.0-r2.ebuild
@@ -10,7 +10,7 @@ PHP_EXT_NAME="geos"
PHP_EXT_OPTIONAL_USE="php"
PHP_EXT_SKIP_PHPIZE="yes"
-inherit php-ext-source-r2 autotools eutils python-single-r1 python-utils-r1
+inherit php-ext-source-r2 autotools eutils python-single-r1
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="http://trac.osgeo.org/geos/"
@@ -20,8 +20,10 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="doc php python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
+ python? ( ${PYTHON_DEPS} )
ruby? ( dev-lang/ruby:* )
"
DEPEND="${RDEPEND}
@@ -30,7 +32,7 @@ DEPEND="${RDEPEND}
dev-lang/swig
app-admin/chrpath
)
- python? ( dev-lang/swig ${PYTHON_DEPS} )
+ python? ( dev-lang/swig )
ruby? ( dev-lang/swig )
"
diff --git a/sci-libs/geos/geos-3.5.0.ebuild b/sci-libs/geos/geos-3.5.0.ebuild
index f0d2f0b4db71..60c7caacb525 100644
--- a/sci-libs/geos/geos-3.5.0.ebuild
+++ b/sci-libs/geos/geos-3.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils python-single-r1 python-utils-r1
+inherit autotools eutils python-single-r1
DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="http://trac.osgeo.org/geos/"
@@ -14,15 +14,17 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="doc php python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
php? ( >=dev-lang/php-5.3:* )
+ python? ( ${PYTHON_DEPS} )
ruby? ( dev-lang/ruby:* )
"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
php? ( dev-lang/swig )
- python? ( dev-lang/swig ${PYTHON_DEPS} )
+ python? ( dev-lang/swig )
ruby? ( dev-lang/swig )
"
diff --git a/sci-libs/geos/geos-3.6.1.ebuild b/sci-libs/geos/geos-3.6.1.ebuild
index f214ee8fbe46..9cf61ce260ad 100644
--- a/sci-libs/geos/geos-3.6.1.ebuild
+++ b/sci-libs/geos/geos-3.6.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
python? ( ${PYTHON_DEPS} )