summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/agda-stdlib')
-rw-r--r--sci-mathematics/agda-stdlib/Manifest1
-rw-r--r--sci-mathematics/agda-stdlib/agda-stdlib-2.4.2.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-mathematics/agda-stdlib/Manifest b/sci-mathematics/agda-stdlib/Manifest
index 3065d6d022f2..baeaa65d8dbd 100644
--- a/sci-mathematics/agda-stdlib/Manifest
+++ b/sci-mathematics/agda-stdlib/Manifest
@@ -1,3 +1,4 @@
DIST agda-stdlib-0.8.tar.gz 246158 SHA256 e8b8380bb03871ee3348aa2df32201a387ca0af02171d32ac58664f58467ed0d SHA512 5ac3bda61eb209a4db650edbbdfb96b73cb58b24e43842957696a20a93454d9846a19e4866af0b736c2c3390184223473da75277e490a6a8348531431ca27af0 WHIRLPOOL ccb5f294cb303b7d502227a6f908fa4904c56c55af1c3897753da3f39c7271cd07c292b56e030b8d80f97e6d6a8ad9f0a5fba1f22e0d169bdb4cb79e6e2db060
DIST agda-stdlib-0.9.tar.gz 248895 SHA256 923b487876235863e4f778aa40c508984b26636d50d531f0f31ca9dc45ab3717 SHA512 aa297e250c5d98ca3f267c5ef95fc33999f9b120256c1983774d814b940a0f5952e524024908e3716af71ad544a586576c1bae6cca19e63797b1d4004ba88413 WHIRLPOOL dd200c61e91e397dfc7de8f6269edaefc20aa3daf5ead9e9fbab62468e5385481a74d5cec62df88e5c5304e06dfbd47b1870f71f70aba7fad29eceb0d836e2b1
DIST agda-stdlib-2.4.2.3.tar.gz 252558 SHA256 bb444fb35096be277c07aa27652c24509449fee9188325bb13eaac68b91eca7d SHA512 d503fc2abd18ab8c367a1947301e0302a6ff9fcbb6376a01f016aa2ab7a9a967e5adb96c5013db1892f4acd9fab62bead11c58c4d443784aff1e42ee4ffd4aa9 WHIRLPOOL 829e5613f2e03cda80608ef0899db413c98a505c9ba595d3aacd12171fc2e30e18e72365770a85655c7670fc5d45103c3b186d2bf8d9697aebae15bc9f40feaf
+DIST agda-stdlib-2.4.2.5.tar.gz 253379 SHA256 9b46956e88a886cd08a8e6e83bea6115844860d7e927279abacc52e84b302b16 SHA512 b15ed5838916240c8602fe7a4bccddf43c71ab3a18ecb5a6dc85199b908e261b04cf794a4d93c90af0a9263a36603c392280639ace7fecead0c39269c2623302 WHIRLPOOL 6414b268a813309e7315d6e2ff9345efdb95d1559966f8755607045a685d4b7cf521750ac7efa8dd90001357d7c825d31589dfd2fe771d379f45d79739c7d66c
diff --git a/sci-mathematics/agda-stdlib/agda-stdlib-2.4.2.5.ebuild b/sci-mathematics/agda-stdlib/agda-stdlib-2.4.2.5.ebuild
new file mode 100644
index 000000000000..8d36ca106bc8
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/agda-stdlib-2.4.2.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal elisp-common
+
+DESCRIPTION="Agda standard library"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="https://github.com/agda/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile +ffi"
+
+# filemanip is used in lib.cabal to make the GenerateEverything and
+# AllNonAsciiChars executables, so agda-stdlib does not require a subslot
+# dependency on filemanip.
+
+RDEPEND="~sci-mathematics/agda-${PV}:=[profile?]
+ >=dev-haskell/filemanip-0.3.6.2[profile?] <dev-haskell/filemanip-0.4[profile?]
+ >=dev-lang/ghc-6.12.1
+ ffi? ( sci-mathematics/agda-lib-ffi )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ cabal-mksetup
+ eapply_user
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+ "${S}"/dist/build/GenerateEverything/GenerateEverything \
+ || die "GenerateEverything failed"
+ local prof
+ use profile && prof="--ghc-flag=-prof"
+ agda +RTS -K1G -RTS ${prof} \
+ -i "${S}" -i "${S}"/src "${S}"/Everything.agda || die
+ # Although my agda-9999 build has
+ # /var/tmp/portage/sci-mathematics/agda-9999/work/agda-9999/dist/build/autogen/Paths_Agda.hs
+ # containing:
+ # datadir = "/usr/share/agda-9999/ghc-7.6.1"
+ # it fails without the --css option like:
+ # /usr/share/agda-9999/ghc-7.4.1/Agda.css: copyFile: does not exist
+ local cssdir=$(egrep 'datadir *=' "${S}/dist/build/autogen/Paths_lib.hs" | sed -e 's@datadir = \(.*\)@\1@')
+ agda --html -i "${S}" -i "${S}"/src --css="${cssdir}/Agda.css" "${S}"/README.agda || die
+}
+
+src_test() {
+ agda -i "${S}" -i "${S}"/src README.agda || die
+}
+
+src_install() {
+ insinto usr/share/agda-stdlib
+ insopts --preserve-timestamps
+ doins -r src/*
+ dodoc -r html/*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}