summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cvc4/cvc4-1.6.ebuild')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.6.ebuild b/sci-mathematics/cvc4/cvc4-1.6.ebuild
new file mode 100644
index 000000000000..1500f9d338da
--- /dev/null
+++ b/sci-mathematics/cvc4/cvc4-1.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="automatic theorem prover for satisfiability modulo theories (SMT) problems"
+HOMEPAGE="http://cvc4.cs.stanford.edu/web/"
+SRC_URI="http://cvc4.cs.stanford.edu/downloads/builds/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cln"
+
+RDEPEND="dev-libs/antlr-c
+ dev-libs/boost
+ cln? ( sci-libs/cln )
+ !cln? ( dev-libs/gmp:= )"
+DEPEND="${RDEPEND}"
+
+src_configure () {
+ econf --enable-gpl \
+ $(use_with cln)
+}