summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/ginac-1.7.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index bfadcbf8dd5f..e939462b2ec7 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -2,3 +2,4 @@ DIST ginac-1.5.8.tar.bz2 1003965 SHA256 8ce72e70f7539e9a2b32539e13eb651fd688d142
DIST ginac-1.6.1.tar.bz2 1048724 SHA256 0658c4a528f37871c5ec24496373fede4e3e59d3223beaf880c75f07a9c2f680 SHA512 5c009e1960d701600f47b306f492b24dccb04cbd4e21d594833db5acf620e230928e1ca471c773918c7d264f057301ddc3a2aa95987d773a9575640ff44f6066 WHIRLPOOL ee95088bd700536ba9246d0145a986b8550d1f2ea479e31b0d8d2bc791f7176e9f2d4d119063626b78156f786f0f44e882429b9a91950c8d130fb8fe7c9d1c57
DIST ginac-1.6.2.tar.bz2 1048764 SHA256 0f34d255024b3fb258e44da84f9e82dfb3dc9bc15f0999b7a18204a730663bde SHA512 6625f9958a1a6167e49d3a3ca442855fa1eab88926565747fda70a8b770db34da0c001f175fa94102ecec1f823d921eba9c98daabd6ed63548bff2b31a3b49cb WHIRLPOOL 40442b8c5820165f4970e95107ce2ac8e22d1c39b60be615d00eefe1f94e061eb6407cf3e8c0bfab15b4b9974168c97ece6cc188c76a8e9484ad9ff065f87962
DIST ginac-1.6.6.tar.bz2 1028211 SHA256 25ec6d535ee77caf6161843688489cfc319b6c4fda46c5d7878587ee5562ddce SHA512 495ef255dd32e71ee91257a515c0566e56525e0c54c8955c19beaf9e2e55457f7d8171c7e5f6e4f29f555f5d262bbaf4edf4f033166c4904c016987a5029e958 WHIRLPOOL c4efc7286377da939ad8196b898086bb67b63102b23c703d3b5fc462be108fc96883597dea50297ec4a26d5bd19f15af8b01c36782c6e6a1886c284cf19771fc
+DIST ginac-1.7.2.tar.bz2 1056339 SHA256 24b75b61c5cb272534e35b3f2cfd64f053b28aee7402af4b0e569ec4de21d8b7 SHA512 5c356beb8e0830b9f5805870f67298d4c19e512db8b8f46a37b490c19179a5c99e4497439e5adb575dd97e7deb5fe0b931a4b6db80e98a8e1e6f46977e33d8cf WHIRLPOOL 7f913725b078dc63bf9dd335b17b813d3e4ee36f21eb932f27d06fbff69feb308d719a4432a3ce6fdd9b84e3d478b523c1a7149fa874ad92106962480a597f0d
diff --git a/sci-mathematics/ginac/ginac-1.7.2.ebuild b/sci-mathematics/ginac/ginac-1.7.2.ebuild
new file mode 100644
index 000000000000..fa64fbc421c4
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.7.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ local myeconfargs=( --disable-rpath )
+ append-cxxflags -std=c++11
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${BUILD_DIR}/doc/reference"
+ emake html pdf
+ cd "${BUILD_DIR}/doc/tutorial"
+ emake ginac.pdf ginac.html
+ fi
+}
+
+src_test() {
+ pushd ../${P}_build > /dev/null
+ emake check
+ popd > /dev/null
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ cd "${BUILD_DIR}"/doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ newins reference/reference.pdf reference.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/doc/examples/*.cpp examples/ginac-examples.*
+ fi
+}