summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/kodkod/Manifest2
-rw-r--r--sci-mathematics/kodkod/files/kodkod-1.5.2-changes-in-most-specific-varargs-method-selection.patch28
-rw-r--r--sci-mathematics/kodkod/kodkod-1.5.2-r1.ebuild141
-rw-r--r--sci-mathematics/kodkod/metadata.xml21
4 files changed, 0 insertions, 192 deletions
diff --git a/sci-mathematics/kodkod/Manifest b/sci-mathematics/kodkod/Manifest
deleted file mode 100644
index 110c95fc9655..000000000000
--- a/sci-mathematics/kodkod/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST kodkod-1.5.2.zip 2092639 BLAKE2B 76bcecb5d1063a7ee0244bfc1496e2684007ea3264a967cf2b8757caff96be872a5d7419f7f6ca1d2a990d5eaaaca8d63af950e66c4eb4453de6fc132d5716a0 SHA512 d55d84e1daabe37c6994fd434c157d5eaecd1d0b2bbe4ab5a2d5e0e529a378d0cb8dc1eac5b89336706f899b23b9682dfd1033f4a2caec76485b12966e091df0
-DIST waf-1.7.16 91846 BLAKE2B 1b95a96d1fb67775c905882d2a6e51a53a586b4e2e88399df13ee25dba870cbc28115ead4aac8a7ee4e8fa2b7593b61b88d0388a874a658b81dc4d33ed3207f8 SHA512 ccdf27cac76f525e11bde20d01c3f81b738b4c990934ee290a390fcf1b278da05047bcee76973c80be4557689344f6df33c13e232b278258745e2f19eeed5ebf
diff --git a/sci-mathematics/kodkod/files/kodkod-1.5.2-changes-in-most-specific-varargs-method-selection.patch b/sci-mathematics/kodkod/files/kodkod-1.5.2-changes-in-most-specific-varargs-method-selection.patch
deleted file mode 100644
index 613d713f0070..000000000000
--- a/sci-mathematics/kodkod/files/kodkod-1.5.2-changes-in-most-specific-varargs-method-selection.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- kodkod-1.5-orig/src/kodkod/util/ints/Ints.java 2011-09-22 19:00:22.000000000 +1000
-+++ kodkod-1.5/src/kodkod/util/ints/Ints.java 2013-02-02 22:30:12.825378928 +1100
-@@ -316,25 +316,6 @@
- }
-
- /**
-- * An implementation of Paul Hsieh's hashing function,
-- * described at http://www.azillionmonkeys.com/qed/hash.html.
-- * The method returns a 32 bit hash of the given objects' hash codes,
-- * or zero if the array is empty. Any null references in the array
-- * are taken to have 0 as their hash code value.
-- * @return a 32 bit hash of the given objects' hashCodes
-- */
-- public static int superFastHash(Object... key) {
-- if (key.length==0) return 0;
-- int hash = key.length;
--
-- for(Object o : key) {
-- hash = superFastHashIncremental(o == null ? 0 : o.hashCode(), hash);
-- }
-- // no end cases since the hashcodes of key parts are ints
-- return superFastHashAvalanche(hash);
-- }
--
-- /**
- * An implementation of an IntSet wrapper for an IntRange.
- */
- private static final class RangeIntSet extends AbstractIntSet {
diff --git a/sci-mathematics/kodkod/kodkod-1.5.2-r1.ebuild b/sci-mathematics/kodkod/kodkod-1.5.2-r1.ebuild
deleted file mode 100644
index 11c25bef00ae..000000000000
--- a/sci-mathematics/kodkod/kodkod-1.5.2-r1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-JAVA_PKG_IUSE="doc source"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='threads(+)'
-
-inherit eutils java-pkg-2 python-any-r1 waf-utils
-
-DESCRIPTION="a constraint solver for relational logic"
-HOMEPAGE="http://alloy.mit.edu/kodkod/index.html"
-SRC_URI="http://alloy.mit.edu/kodkod/${PV}/${P}.zip
- https://waf.googlecode.com/files/waf-1.7.16"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEP="${PYTHON_DEPS}"
-RDEPEND="${COMMON_DEP}
- >=virtual/jre-1.6"
-DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.6
- app-arch/unzip"
-
-S="${WORKDIR}/kodkod-1.5"
-
-JAVA_SRC_DIR="src"
-
-pkg_setup() {
- python-any-r1_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- unpack "${A% *}"
- cp "${DISTDIR}/${A#* }" "${S}/waf" || die "Could not copy waf"
-}
-
-src_prepare() {
- java-pkg-2_src_prepare
- chmod u+x waf \
- || die "Could not set execute permisions on waf file"
- sed -e 's@private N parent, left, right@protected N parent, left, right@' \
- -e 's@private boolean color@protected boolean color@' \
- -i "${S}/src/kodkod/util/ints/IntTree.java" \
- || die "Could not change private to protected in IntTree.java"
- sed -e 's@conf.env.LINKFLAGS =@conf.env.LINKFLAGS +=@' \
- -i "${S}/lib/cryptominisat-2.9.1/wscript" \
- -i "${S}/lib/lingeling-276/wscript" \
- || die "Could not fix wscripts to respect LDFLAGS"
- # Fix bug 453162 - sci-mathematics/kodkod-1.5.2: fails to build
- epatch "${FILESDIR}/${PN}-1.5.2-changes-in-most-specific-varargs-method-selection.patch"
-
- # Fix Bug 458462 sci-mathematics/kodkod-1.5.2: fails to build with JAVA_PKG_STRICT
- local x=""
- for i in $JAVACFLAGS
- do
- if [ "${x}" == "" ]; then
- x="'${i}'"
- else
- x="${x}, '${i}'"
- fi
- done
- for j in $(find . -name wscript -print)
- do
- sed -e "s@def configure(conf):@def configure(conf):\n conf.env.JAVACFLAGS = [${x}]@" \
- -i "${j}" \
- || die "Could not set JAVACFLAGS in ${j}"
- done
-}
-
-# note: kodkod waf fails when passed --libdir:
-# waf: error: no such option: --libdir
-src_configure() {
- ${WAF_BINARY:="${S}/waf"}
-
- tc-export AR CC CPP CXX RANLIB
- echo "CCFLAGS=\"${CFLAGS}\" LINKFLAGS=\"${LDFLAGS}\" \"${WAF_BINARY}\" --prefix=${EPREFIX}/usr $@ configure"
-
- CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
- "--prefix=${EPREFIX}/usr" \
- "$@" \
- configure || die "configure failed"
-}
-
-src_compile() {
- waf-utils_src_compile
- if has doc ${JAVA_PKG_IUSE} && use doc; then
- pushd src/kodkod || die "Could not cd to src/kodkod"
- local doclint="-Xdoclint:none"
- local jv="$(javac -version 2>&1 | cut -d' ' -f 2)"
- if [[ "${jv}" == 1.6* ]] || [[ "${jv}" == 1.7* ]]; then
- doclint=""
- fi
- javadoc ${doclint} -sourcepath "${S}"/src/kodkod:"${S}"/build/src/kodkod \
- -classpath $(find "${PWD}" -name \*.jar -print | xargs | sed -e 's@ @:@g') \
- $(find . -name \*.java -print) \
- || die "javadoc failed"
- popd
- fi
-}
-
-src_install() {
- insinto "/usr/"$(get_libdir)
- dodir "/usr/"$(get_libdir)"/${PN}"
- exeinto "/usr/"$(get_libdir)"/${PN}"
- for i in $(find . \( -name \*.so -o -name plingeling \) -print | xargs); do
- doexe $i
- done
-
- for i in $(find . \( -name kodkod.jar -o -name org.sat4j.core.jar \) -print | xargs); do
- einfo "java-pkg_dojar $i"
- java-pkg_dojar $i
- done
-
- # javadoc
- if has doc ${JAVA_PKG_IUSE} && use doc; then
- java-pkg_dojavadoc src/kodkod
- fi
-
- # dosrc
- if has source ${JAVA_PKG_IUSE} && use source; then
- local srcdirs=""
- if [[ ${JAVA_SRC_DIR} ]]; then
- local parent child
- for parent in ${JAVA_SRC_DIR}; do
- for child in ${parent}/*; do
- srcdirs="${srcdirs} ${child}"
- done
- done
- else
- # take all directories actually containing any sources
- srcdirs="$(cut -d/ -f1 ${sources} | sort -u)"
- fi
- java-pkg_dosrc ${srcdirs}
- fi
-}
diff --git a/sci-mathematics/kodkod/metadata.xml b/sci-mathematics/kodkod/metadata.xml
deleted file mode 100644
index a204ce809b84..000000000000
--- a/sci-mathematics/kodkod/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>gienah@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
-Kodkod is an efficient SAT-based constraint solver for first order
-logic with relations, transitive closure, bit-vector arithmetic, and
-partial models. It provides analyses for both satisfiable and
-unsatisfiable problems: a finite model finder for the former and a
-minimal unsatisfiable core extractor for the latter. Kodkod is used in
-a wide range of applications, including code checking, test-case
-generation, declarative execution, declarative configuration, and
-lightweight analysis of Alloy, UML, and Isabelle/HOL.
-</longdescription>
-</pkgmetadata>