summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/boinc/files/7.10-fix_xlocale.patch')
-rw-r--r--sci-misc/boinc/files/7.10-fix_xlocale.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-misc/boinc/files/7.10-fix_xlocale.patch b/sci-misc/boinc/files/7.10-fix_xlocale.patch
new file mode 100644
index 000000000000..6d2360138f8b
--- /dev/null
+++ b/sci-misc/boinc/files/7.10-fix_xlocale.patch
@@ -0,0 +1,37 @@
+--- a/configure.ac 2018-03-21 12:08:02.287768932 +0100
++++ b/configure.ac 2018-03-21 12:09:32.918771652 +0100
+@@ -592,7 +592,7 @@
+ echo "DEBUG: GLUT_CFLAGS = $GLUT_CFLAGS" >&5
+ echo "DEBUG: GLUT_LIBS = $GLUT_LIBS" >&5
+
+- AC_CHECK_HEADERS([gl.h glu.h glut.h glaux.h GL/gl.h GL/glu.h GL/glut.h GL/glaux.h OpenGL/gl.h OpenGL/glu.h OpenGL/glut.h OpenGL/glaux.h GLUT/glut.h MesaGL/gl.h MesaGL/glu.h MesaGL/glut.h MesaGL/glaux.h libnotify/notify.h gtk/gtk.h locale.h xlocale.h])
++ AC_CHECK_HEADERS([gl.h glu.h glut.h glaux.h GL/gl.h GL/glu.h GL/glut.h GL/glaux.h OpenGL/gl.h OpenGL/glu.h OpenGL/glut.h OpenGL/glaux.h GLUT/glut.h MesaGL/gl.h MesaGL/glu.h MesaGL/glut.h MesaGL/glaux.h libnotify/notify.h gtk/gtk.h locale.h])
+
+ AC_CHECK_LIB([jpeg], [jpeg_start_compress],[have_jpeg=1],[have_jpeg=0])
+ AC_CHECK_HEADER([jpeglib.h],[have_jpeg=1],[have_jpeg=0])
+--- a/lib/gui_rpc_client.h 2018-03-21 12:07:51.300768602 +0100
++++ b/lib/gui_rpc_client.h 2018-03-21 12:09:11.671771015 +0100
+@@ -810,8 +810,8 @@
+
+ #elif defined(__APPLE__) && (MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_4)
+ // uselocale() is not available in OS 10.3.9 so use weak linking
+-#if HAVE_XLOCALE_H
+-#include <xlocale.h>
++#if HAVE_LOCALE_H
++#include <locale.h>
+ #endif
+ extern int freelocale(locale_t) __attribute__((weak_import));
+ extern locale_t newlocale(int, __const char *, locale_t) __attribute__((weak_import));
+--- a/clientgui/AsyncRPC.cpp 2018-03-21 12:08:17.241769380 +0100
++++ b/clientgui/AsyncRPC.cpp 2018-03-21 12:08:50.664770384 +0100
+@@ -19,8 +19,8 @@
+ #pragma implementation "AsyncRPC.h"
+ #endif
+
+-#if HAVE_XLOCALE_H
+-#include <xlocale.h>
++#if HAVE_LOCALE_H
++#include <locale.h>
+ #endif
+
+ #include "stdwx.h"