summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/boinc-7.8.4.ebuild2
-rw-r--r--sci-misc/boinc/files/fix_xlocale.patch42
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-misc/boinc/boinc-7.8.4.ebuild b/sci-misc/boinc/boinc-7.8.4.ebuild
index b4628e19804e..3c1024ee2da2 100644
--- a/sci-misc/boinc/boinc-7.8.4.ebuild
+++ b/sci-misc/boinc/boinc-7.8.4.ebuild
@@ -55,6 +55,8 @@ DEPEND="${RDEPEND}
PATCHES=(
# >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
"${FILESDIR}"/fix_webview.patch
+ # xlocale.h was removed in modern glibc, bug 639108
+ "${FILESDIR}"/fix_xlocale.patch
)
S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
diff --git a/sci-misc/boinc/files/fix_xlocale.patch b/sci-misc/boinc/files/fix_xlocale.patch
new file mode 100644
index 000000000000..8b80258cf6c1
--- /dev/null
+++ b/sci-misc/boinc/files/fix_xlocale.patch
@@ -0,0 +1,42 @@
+--- a/configure.ac 2017-12-18 17:45:19.829854890 +0100
++++ b/configure.ac 2017-12-18 17:46:13.845853923 +0100
+@@ -602,7 +602,7 @@
+ echo "DEBUG: GLUT_CFLAGS = $GLUT_CFLAGS" >&5
+ echo "DEBUG: GLUT_LIBS = $GLUT_LIBS" >&5
+
+- AC_CHECK_HEADERS([gl.h glu.h glut.h glaux.h GL/gl.h GL/glu.h GL/glut.h GL/glaux.h OpenGL/gl.h OpenGL/glu.h OpenGL/glut.h OpenGL/glaux.h GLUT/glut.h MesaGL/gl.h MesaGL/glu.h MesaGL/glut.h MesaGL/glaux.h libnotify/notify.h gtk/gtk.h locale.h xlocale.h])
++ AC_CHECK_HEADERS([gl.h glu.h glut.h glaux.h GL/gl.h GL/glu.h GL/glut.h GL/glaux.h OpenGL/gl.h OpenGL/glu.h OpenGL/glut.h OpenGL/glaux.h GLUT/glut.h MesaGL/gl.h MesaGL/glu.h MesaGL/glut.h MesaGL/glaux.h libnotify/notify.h gtk/gtk.h locale.h])
+
+ AC_CHECK_LIB([jpeg], [jpeg_start_compress],[have_jpeg=1],[have_jpeg=0])
+ AC_CHECK_HEADER([jpeglib.h],[have_jpeg=1],[have_jpeg=0])
+@@ -986,9 +986,6 @@
+ #ifdef HAVE_LOCALE_H
+ #include <locale.h>
+ #endif
+-#ifdef HAVE_XLOCALE_H
+-#include <xlocale.h>
+-#endif
+ ]])
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+--- a/lib/gui_rpc_client.h 2017-12-18 17:47:22.826852688 +0100
++++ b/lib/gui_rpc_client.h 2017-12-18 17:48:42.384851263 +0100
+@@ -807,7 +807,6 @@
+
+ #elif defined(__APPLE__) && (MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_4)
+ // uselocale() is not available in OS 10.3.9 so use weak linking
+-#include <xlocale.h>
+ extern int freelocale(locale_t) __attribute__((weak_import));
+ extern locale_t newlocale(int, __const char *, locale_t) __attribute__((weak_import));
+ extern locale_t uselocale(locale_t) __attribute__((weak_import));
+--- a/clientgui/AsyncRPC.cpp 2017-12-18 17:47:30.727852546 +0100
++++ b/clientgui/AsyncRPC.cpp 2017-12-18 17:48:56.785851005 +0100
+@@ -20,7 +20,7 @@
+ #endif
+
+ #if !(defined(_WIN32) || (defined(__WXMAC__) && (MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_4)))
+-#include <xlocale.h>
++#include <locale.h>
+ #endif
+
+ #include "stdwx.h"