summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/nco')
-rw-r--r--sci-misc/nco/nco-4.5.1-r2.ebuild51
1 files changed, 28 insertions, 23 deletions
diff --git a/sci-misc/nco/nco-4.5.1-r2.ebuild b/sci-misc/nco/nco-4.5.1-r2.ebuild
index 850672c5b053..a1cd22244bb6 100644
--- a/sci-misc/nco/nco-4.5.1-r2.ebuild
+++ b/sci-misc/nco/nco-4.5.1-r2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils eutils flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Command line utilities for operating on netCDF files"
HOMEPAGE="http://nco.sourceforge.net/"
@@ -13,37 +12,43 @@ SRC_URI="http://nco.sf.net/src/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0/${PV}"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="dap doc gsl ncap2 openmp static-libs test udunits"
+IUSE="dap gsl hdf5 ncap2 openmp static-libs test udunits"
RDEPEND="
- >=sci-libs/netcdf-4:=[dap=,tools]
+ >=sci-libs/netcdf-4:=[dap=,hdf5?,tools]
gsl? ( sci-libs/gsl:= )
ncap2? ( dev-cpp/antlr-cpp:2= )
udunits? ( >=sci-libs/udunits-2 )"
-
DEPEND="${RDEPEND}
test? ( >=sci-libs/netcdf-4[tools] )"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_configure() {
- local myeconfargs=(
- --disable-udunits
- $(use_enable dap dap-netcdf)
- $(use_enable gsl)
- $(use_enable ncap2)
- $(use_enable openmp)
+ use hdf5 && append-cppflags -DHAVE_NETCDF4_H
+
+ econf \
+ --disable-udunits \
+ $(use_enable dap) \
+ $(use_enable gsl) \
+ $(use_enable hdf5 netcdf4) \
+ $(use_enable ncap2) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static) \
$(use_enable udunits udunits2)
- )
- if has_version '>=sci-libs/netcdf-4[hdf5]'; then
- myeconfargs+=( --enable-netcdf4 )
- append-cppflags -DHAVE_NETCDF4_H
- else
- myeconfargs+=( --disable-netcdf4 )
- fi
- autotools-utils_src_configure
}
src_install() {
- use doc && DOCS=( doc/nco.pdf ) && HTML_DOCS=( doc/nco.html )
- autotools-utils_src_install
+ default
doinfo doc/*.info*
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
}