summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/boinc-7.8.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-misc/boinc/boinc-7.8.4.ebuild b/sci-misc/boinc/boinc-7.8.4.ebuild
index 3c1024ee2da2..b1ddba69aff0 100644
--- a/sci-misc/boinc/boinc-7.8.4.ebuild
+++ b/sci-misc/boinc/boinc-7.8.4.ebuild
@@ -136,6 +136,8 @@ src_install() {
}
pkg_preinst() {
+ gnome2_icon_savelist
+
enewgroup ${PN}
# note this works only for first install so we have to
# elog user about the need of being in video group
@@ -147,7 +149,9 @@ pkg_preinst() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
elog
elog "You are using the source compiled version of boinc."
@@ -185,5 +189,7 @@ pkg_postinst() {
}
pkg_postrm() {
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
}