summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/spyview/spyview-20111018.ebuild')
-rw-r--r--sci-visualization/spyview/spyview-20111018.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-visualization/spyview/spyview-20111018.ebuild b/sci-visualization/spyview/spyview-20111018.ebuild
new file mode 100644
index 000000000000..4252f092e489
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20111018.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic eutils multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.42
+ media-libs/netpbm
+ x11-libs/fltk:1[opengl]
+ app-text/ghostscript-gpl
+ virtual/glu
+"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+src_unpack() {
+ default
+ mv -v "${WORKDIR}"/spyview-20* "${S}" || die
+}
+
+src_prepare() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L$(dirname $(fltk-config --libs))
+
+ find "${S}" -name Makefile.in -exec sed -i -e 's:-mwindows -mconsole::g' {} + || die
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview --docdir=/usr/share/doc/${PF}
+}