summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sec-policy/selinux-base/selinux-base-2.20180701-r1.ebuild')
-rw-r--r--sec-policy/selinux-base/selinux-base-2.20180701-r1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/sec-policy/selinux-base/selinux-base-2.20180701-r1.ebuild b/sec-policy/selinux-base/selinux-base-2.20180701-r1.ebuild
index 020f30cfb94e..c27d17d32999 100644
--- a/sec-policy/selinux-base/selinux-base-2.20180701-r1.ebuild
+++ b/sec-policy/selinux-base/selinux-base-2.20180701-r1.ebuild
@@ -72,7 +72,7 @@ src_configure() {
# Prepare initial configuration
cd "${S}/refpolicy" || die
- emake conf || die "Make conf failed"
+ emake conf
# Setup the policies based on the types delivered by the end user.
# These types can be "targeted", "strict", "mcs" and "mls".
@@ -125,11 +125,8 @@ src_install() {
for i in ${POLICY_TYPES}; do
cd "${S}/${i}" || die
- emake DESTDIR="${D}" install \
- || die "${i} install failed."
-
- emake DESTDIR="${D}" install-headers \
- || die "${i} headers install failed."
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install-headers
echo "run_init_t" > "${D}/etc/selinux/${i}/contexts/run_init_type" || die