summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpuid/cpuid-20180419.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20180419.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20180419.ebuild b/sys-apps/cpuid/cpuid-20180419.ebuild
new file mode 100644
index 000000000000..b4c973068b48
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20180419.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-arch/gzip
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20170122-Makefile.patch
+ "${FILESDIR}"/${PN}-20170122-missing-include-sysmacros.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+ einstalldocs
+}