summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20180419.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 9701a754261e..07dfe7c7e94f 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20170122.src.tar.gz 80046 BLAKE2B 4c6c6719f57b446c92c5636a35aac883497d457719c67acb61db75ce99c46edee368d63e790b6b21ea334293aaed221374229e334cefcc65ea8b05c8ae40d172 SHA512 0e057980c71a0e078254e6b7535747bdf368278932c39943cf7dfafe08443af07297a2b41518499937a710fe6950ba89377cabaada5f6332932650d4d17c1430
+DIST cpuid-20180419.src.tar.gz 82301 BLAKE2B 6905c0946fb9a930c67718067923c8c238031539c95704664160efde8563b0f56aadf3132abc9833310846802f97330edff833b47c006a4f46fec49358b56e31 SHA512 c8e30e45df7be5bdbff7e449b447b4542326a112f563c114c67cc80764070f3f3815ff4f80ceb57360828061bc9fd5f2f24f8e53ae4db47781f36db32141c951
diff --git a/sys-apps/cpuid/cpuid-20180419.ebuild b/sys-apps/cpuid/cpuid-20180419.ebuild
new file mode 100644
index 000000000000..b4c973068b48
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20180419.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-arch/gzip
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20170122-Makefile.patch
+ "${FILESDIR}"/${PN}-20170122-missing-include-sysmacros.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+ einstalldocs
+}