summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dnotify/dnotify-0.18.0.ebuild')
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
index 440759ad96ac..5a207d27f378 100644
--- a/sys-apps/dnotify/dnotify-0.18.0.ebuild
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="Execute a command when the contents of a directory change"
-HOMEPAGE="http://directory.fsf.org/project/dnotify/"
+HOMEPAGE="https://directory.fsf.org/project/dnotify/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
@@ -16,10 +15,10 @@ IUSE="nls"
RDEPEND=""
DEPEND="nls? ( sys-devel/gettext )"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-nls.patch \
- "${FILESDIR}"/${P}-glibc-212.patch
-}
+PATCHES=(
+ "${FILESDIR}/${P}-nls.patch"
+ "${FILESDIR}/${P}-glibc-212.patch"
+)
src_configure() {
econf \
@@ -28,5 +27,5 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS TODO NEWS README
+ default
}