summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gradm/gradm-3.1.201903191516.ebuild')
-rw-r--r--sys-apps/gradm/gradm-3.1.201903191516.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-apps/gradm/gradm-3.1.201903191516.ebuild b/sys-apps/gradm/gradm-3.1.201903191516.ebuild
index 95fe975573eb..85bccb3730eb 100644
--- a/sys-apps/gradm/gradm-3.1.201903191516.ebuild
+++ b/sys-apps/gradm/gradm-3.1.201903191516.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit flag-o-matic toolchain-funcs udev
MY_PV="$(ver_rs 2 -)"
@@ -17,8 +18,8 @@ IUSE="pam"
RDEPEND=""
DEPEND="
- sys-devel/bison
- sys-devel/flex
+ app-alternatives/yacc
+ app-alternatives/lex
pam? ( sys-libs/pam )"
S=${WORKDIR}/${PN}
@@ -36,6 +37,9 @@ src_compile() {
local target
use pam || target="nopam"
+ # bug #863569
+ filter-lto
+
emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}"
}