summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/guix/guix-1.0.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-apps/guix/guix-1.0.1.ebuild b/sys-apps/guix/guix-1.0.1.ebuild
index 475d3bba8b83..cb8689ab8712 100644
--- a/sys-apps/guix/guix-1.0.1.ebuild
+++ b/sys-apps/guix/guix-1.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools readme.gentoo-r1 systemd user
+inherit autotools linux-info readme.gentoo-r1 systemd user
DESCRIPTION="GNU package manager (nix sibling)"
HOMEPAGE="https://www.gnu.org/software/guix/"
@@ -90,6 +90,13 @@ Next steps:
guix package manager user manual: https://www.gnu.org/software/guix/manual/guix.html
"
+pkg_pretend() {
+ # USER_NS is used to run builders in a default setting in linux
+ # and for 'guix environment --container'.
+ local CONFIG_CHECK="~USER_NS"
+ check_extra_config
+}
+
pkg_setup() {
enewgroup guixbuild
for i in {1..10}; do