summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fwupd/Manifest1
-rw-r--r--sys-apps/fwupd/fwupd-1.2.7.ebuild143
2 files changed, 144 insertions, 0 deletions
diff --git a/sys-apps/fwupd/Manifest b/sys-apps/fwupd/Manifest
index 7feb538b37b5..d34ea680affc 100644
--- a/sys-apps/fwupd/Manifest
+++ b/sys-apps/fwupd/Manifest
@@ -1,2 +1,3 @@
DIST fwupd-1.2.5.tar.gz 1818559 BLAKE2B 0d30248bf3be093d3764624294fdd6e26b979560d70b47e67b3ca5f213177d807e749f5e30abd4d7d7d15e4be507103583834062b6a3243367169019e24a1bc7 SHA512 dc6a0def49225ce50bc89c3f76137497d4c8b71f94e42546fbf5221dc0af504ce6090f803ea9dca175f6166ff1341f6a3eab04652d744257c9e88dbd6875abc7
DIST fwupd-1.2.6.tar.gz 1861765 BLAKE2B 160af03c0c08bed730657520a15f96c9881996807d186a26074f10b6b340e27b0e783ae7a6b1fc433e4347cba535d49bca60b4d242101a9097fc2749f3cca0ee SHA512 c1111fd881126bf85424dec004e4321948cbdd603ed79989eee51f48197f8f0f391371834964dd1bff52eb3b353cc4c2e5714f6ff674b23dbd8e8d0e8a87ff27
+DIST fwupd-1.2.7.tar.gz 1899554 BLAKE2B aed0377135354c6391f63eb0802d27b5359efdb0f9d3b5c1a55ba8fe7ef0c84c9201e689d8a1bdde998e8147b25767e4dc7586c57bcf33e9f9e9d807e38e7a04 SHA512 12b5c193ab6e55e14256ea84273d139e7353618b6524197ba1f4477db32071e33a73b3e2e2b34733ca6269c4dbad5a03f2d3546b27d22b2a6db23989c69be6e5
diff --git a/sys-apps/fwupd/fwupd-1.2.7.ebuild b/sys-apps/fwupd/fwupd-1.2.7.ebuild
new file mode 100644
index 000000000000..08dacdd46935
--- /dev/null
+++ b/sys-apps/fwupd/fwupd-1.2.7.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit meson python-single-r1 vala xdg-utils
+
+DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable"
+HOMEPAGE="https://fwupd.org"
+SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="agent colorhug dell doc elogind +gpg +man nvme pkcs7 redfish systemd test thunderbolt uefi"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )
+ dell? ( uefi )
+"
+
+RDEPEND="${PYTHON_DEPS}
+ app-arch/gcab
+ app-arch/libarchive:=
+ dev-db/sqlite
+ >=dev-libs/glib-2.45.8:2
+ dev-libs/json-glib
+ dev-libs/libgpg-error
+ dev-libs/libgudev:=
+ >=dev-libs/libgusb-0.2.9[introspection]
+ >=dev-libs/libxmlb-0.1.7
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=net-libs/libsoup-2.51.92:2.4[introspection]
+ >=sys-auth/polkit-0.103
+ virtual/libelf:0=
+ colorhug? ( >=x11-misc/colord-1.2.12:0= )
+ dell? (
+ sys-libs/efivar
+ >=sys-libs/libsmbios-2.4.0
+ )
+ gpg? (
+ app-crypt/gpgme
+ dev-libs/libgpg-error
+ )
+ nvme? ( sys-libs/efivar )
+ pkcs7? ( >=net-libs/gnutls-3.4.4.1:= )
+ redfish? ( sys-libs/efivar )
+ !systemd? (
+ !elogind? ( >=sys-auth/consolekit-1.0.0 )
+ elogind? ( sys-auth/elogind )
+ )
+ systemd? ( >=sys-apps/systemd-211 )
+ thunderbolt? ( sys-apps/thunderbolt-software-user-space )
+ uefi? (
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-boot/gnu-efi
+ >=sys-libs/efivar-33
+ x11-libs/cairo
+ )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ x11-libs/pango[introspection]
+ nvme? ( >=sys-kernel/linux-headers-4.4 )
+ test? ( net-libs/gnutls[tools] )
+"
+BDEPEND="
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ man? ( app-text/docbook-sgml-utils )
+"
+
+# required for fwupd daemon to run.
+# NOT a build time dependency. The build system does not check for dbus.
+PDEPEND="sys-apps/dbus"
+
+src_prepare() {
+ default
+ sed -e "s/'--create'/'--absolute-name', '--create'/" \
+ -i data/tests/builder/meson.build || die
+ sed -e "/'-Werror',/d" \
+ -i plugins/uefi/efi/meson.build || die
+ vala_src_prepare
+}
+
+src_configure() {
+ xdg_environment_reset
+ local emesonargs=(
+ --localstatedir "${EPREFIX}"/var
+ -Dagent="$(usex agent true false)"
+ -Dgtkdoc="$(usex doc true false)"
+ -Delogind="$(usex elogind true false)"
+ -Dgpg="$(usex gpg true false)"
+ -Dman="$(usex man true false)"
+ -Dpkcs7="$(usex pkcs7 true false)"
+ -Dplugin_dell="$(usex dell true false)"
+ # Dependencies are not available (yet?)
+ -Dplugin_modem_manager="false"
+ -Dplugin_nvme="$(usex nvme true false)"
+ -Dplugin_redfish="$(usex redfish true false)"
+ -Dplugin_synaptics="$(usex dell true false)"
+ -Dplugin_thunderbolt="$(usex thunderbolt true false)"
+ -Dplugin_uefi="$(usex uefi true false)"
+ -Dsystemd="$(usex systemd true false)"
+ -Dtests="$(usex test true false)"
+ )
+
+ if use elogind || use systemd ; then
+ emesonargs+=( -Dconsolekit=false )
+ else
+ emesonargs+=( -Dconsolekit=true )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ sed "s@%SEAT_MANAGER%@$(usex elogind elogind consolekit)@" \
+ "${FILESDIR}"/${PN}-r1 \
+ > "${T}"/${PN} || die
+ doinitd "${T}"/${PN}
+
+ if ! use systemd ; then
+ # Don't timeout when fwupd is running (#673140)
+ sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \
+ -i "${ED}"/etc/${PN}/daemon.conf || die
+ fi
+}
+
+pkg_postinst() {
+ elog "In case you are using openrc as init system"
+ elog "and you're upgrading from <fwupd-1.1.0, you"
+ elog "need to start the fwupd daemon via the openrc"
+ elog "init script that comes with this package."
+}