summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.20.2.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.20.2.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.20.2.ebuild
new file mode 100644
index 000000000000..869fe92ebae0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.20.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index ecaad91b6b78..8b5c7d67a291 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.20.1.tar.gz 10103225 BLAKE2B 79afb6e793827bec16c0ba4830d87e4ab5da35a76cb1ce1a9e59ee70a7e8c7606ae1f2244ac73fbe6ac758d559451dbaefe7cc4ad9f49adb33228af3d2647051 SHA512 08e51207bca38871b6cfc3146fa5252bd18bc018d91b7c4cb847519b0282aa5d0e6ff40ffa0bf389c421fed0d40855044e7eb9e0630ca8dc639c263d3055c1bf
+DIST AusweisApp2-1.20.2.tar.gz 10110603 BLAKE2B cb3063decb3a5aacbc1d7690c58566914776032cd305d29f6352df659a27dcf81e07550613809849822ee20d7aaa467303f33602c40aaa39a99501daa7d1e887 SHA512 4a968d3d9043f9eba5927f049155e203448a27034f0c051c10fbaa262bb7b4257c5a6de4763c1fa470a1c46d51bf67636f14c136c7e7c8038eab7e929dcb38c2