summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/arcconf')
-rw-r--r--sys-block/arcconf/Manifest1
-rw-r--r--sys-block/arcconf/arcconf-3.01.23531.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-block/arcconf/Manifest b/sys-block/arcconf/Manifest
index 38ed1ed108be..99e7009057bc 100644
--- a/sys-block/arcconf/Manifest
+++ b/sys-block/arcconf/Manifest
@@ -1,2 +1,3 @@
DIST arcconf_v2_01_22270.zip 47168976 BLAKE2B 95693a1408e5a4d0d638bbf265f2e1e64247dfec2b1078b56860c5fcd4b13ffa5967bfb9967abfd4b79c788aaeb20759b3a9070a84b083c1653e4868a96ac4cf SHA512 0f91a697c44ea0c0561bec9e432e7d4eba8eb8a2b0255a9867bdb183f81e745aee1dcc2b0017847803dbb27f55cad3e985f4bcd3a202c52f5b557fb724e94d9e
DIST arcconf_v2_06_23168_h.zip 76933066 BLAKE2B a0bad8832bfc9a1d48de8738764dbf30148f344a855679c220ee40426bfee0b83c2ed82fd4c8ae32bc81df90c9c762c5a9ed0ee3466501eb60b605ea2e446c15 SHA512 668261fa6224a7d1bc18ddbf0d4610ee218f23217bfc600be6b3fe5c2fda929e43168d98120aa4942ae4e40a853fcc988e027ba90357f6e6f7960756e1e202dd
+DIST arcconf_v3_01_23531.zip 76188493 BLAKE2B bb939262e89a76fe28cca60ce647df53bd66625d8273cf80ad0b9daa31de8ac33d181a5ad864e52ce5b599d9631a503d2e4a132ec3369b67f0e12887a4bccc0c SHA512 93ab1b5f3f35ad403ac52456ffb16b5b57c4851dbaa3d4922194b29b72957944a0a3e02346362f62b3f6ba5f73394a3720a1f5a371b34e9a03f31bd793348822
diff --git a/sys-block/arcconf/arcconf-3.01.23531.ebuild b/sys-block/arcconf/arcconf-3.01.23531.ebuild
new file mode 100644
index 000000000000..71d1211cab8e
--- /dev/null
+++ b/sys-block/arcconf/arcconf-3.01.23531.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="v${PV//./_}"
+
+inherit linux-info
+
+DESCRIPTION="Microsemi Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="https://www.microsemi.com/"
+SRC_URI="https://download.adaptec.com/raid/storage_manager/${PN}_${MY_PV}.zip"
+
+LICENSE="Microsemi"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/linux_x64"
+
+QA_PREBUILT="usr/bin/arcconf"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://storage.microsemi.com/en-us/speed/raid/storage_manager/${PN}_${MY_PV}_zip.php"
+ elog "and place it in your DISTDIR directory."
+}
+
+pkg_setup() {
+ # CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+ if linux-info_get_any_version && linux_config_src_exists ; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ dobin arcconf
+}