summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/arcconf')
-rw-r--r--sys-block/arcconf/Manifest1
-rw-r--r--sys-block/arcconf/arcconf-2.05.22932.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/arcconf/Manifest b/sys-block/arcconf/Manifest
index 20311a1240c8..117b9ba402a8 100644
--- a/sys-block/arcconf/Manifest
+++ b/sys-block/arcconf/Manifest
@@ -1,3 +1,4 @@
DIST arcconf_v1_2_20618.zip 11920300 BLAKE2B c0ee178216a369ee16a49a97a7a5a8948e10c0dc6b1791ce536f4a23eefb90a9702fb24c1d899916e7d5012ec1e79b0f55bfc3e6e0f9848de2f20b15ccabae2c SHA512 e8415e929cd7a8c8bca33f0de29bdadf3595da911bc3c0984226e02e01e6f4e9c822363dd8aa093efd524eea19f0689784e0300403513a99ead14ac08c487efe
DIST arcconf_v1_7_21229.zip 11056748 BLAKE2B d867eb3fe8ddb1e2429b91b33dcfddc4730e1ebc82eca019ad0d2d7fbea92ae421482d0bb62e5a6c28d98b5655ff4a6c8e9f73228d5cb398c1bc23428ecdeb90 SHA512 66a56ea66b8011c1f8f431b25f95050e541311ee415a0d4bdee6ef6416ff499be41d275819694384f66e5a1401b467da82ab15ce7c3fe49e1e013370293cf63a
DIST arcconf_v2_04_22665.zip 35218069 BLAKE2B 77664d219e3262c5302f53924f1182ddc6385b0987072b9c50aaa5591c651766e48d5e5a7ec8c4cf8fab3d8930f322204c3f90d2170fbe041adb69a221fe9667 SHA512 33810ec898935c98c955d869fa443e259761fbd1c329a95a1f85bfca50d25685f6a050eeda535daa81221a922dc094a9ff079080a3969bab826874424dcf85e2
+DIST arcconf_v2_05_22932.zip 58966959 BLAKE2B 7a809e4e3fcbbf915fec399a90064a82ec4fd70526ce3ee51036b55a030e6fdffe2d9e502618456aee68d247e0de2b986ee9f85f15a1f42a366f7498ced9fe8e SHA512 73b30ac06301ab97b42ff86f92a11968b4e4f9fac83bee4cdb57c0096ccdf9bec1adbd1d4b192dcaf5d112b8a5181a52e291df1f5a10e4aa1d25e72070119c96
diff --git a/sys-block/arcconf/arcconf-2.05.22932.ebuild b/sys-block/arcconf/arcconf-2.05.22932.ebuild
new file mode 100644
index 000000000000..2f607e620d68
--- /dev/null
+++ b/sys-block/arcconf/arcconf-2.05.22932.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info
+
+DESCRIPTION="Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="http://www.adaptec.com/en-us/downloads/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_v${PV//./_}.zip"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Adaptec-EULA"
+SLOT="0"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+# RESTRICT="fetch"
+
+QA_PRESTRIPPED="/opt/bin/arcconf"
+
+S="${WORKDIR}"
+
+# Maintainer notes:
+# * When going via the $HOMEPAGE one has to agree to the Adaptec-EULA as
+# referenced above.
+# * Despite that EULA, one can download the package seemingly without
+# restrictions from $SRC_URI.
+# * It is therefore assumed that the binary is made available for public
+# download. Even more so since the archive does not contain a license
+# agreement stating otherwise.
+
+#pkg_nofetch() {
+# einfo "Upstream has implemented a mandatory clickthrough EULA for distfile download"
+# einfo "Please visit $HOMEPAGE, choose a controller (for example the Series 7, 7805)"
+# einfo "and then navigate to Storage Manager Downloads for the ARCCONF Command Line Utility."
+# einfo "And place $A in ${DISTDIR}"
+#}
+
+# Maintainer notes:
+# * FreeBSD binaries would be available for FreeBSD 7..9, which ones do we need?
+
+# CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+pkg_setup() {
+ if linux-info_get_any_version && linux_config_src_exists ; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ exeinto /opt/bin
+
+ if use amd64; then
+ doexe linux_x64/cmdline/arcconf
+ else
+ doexe linux/cmdline/arcconf
+ fi
+}