summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/parted')
-rw-r--r--sys-block/parted/files/parted-3.3-atari.patch11
-rw-r--r--sys-block/parted/parted-3.3-r1.ebuild (renamed from sys-block/parted/parted-3.3.ebuild)3
2 files changed, 13 insertions, 1 deletions
diff --git a/sys-block/parted/files/parted-3.3-atari.patch b/sys-block/parted/files/parted-3.3-atari.patch
new file mode 100644
index 000000000000..41771d02d4ee
--- /dev/null
+++ b/sys-block/parted/files/parted-3.3-atari.patch
@@ -0,0 +1,11 @@
+--- a/libparted/labels/atari.c
++++ b/libparted/labels/atari.c
+@@ -1957,7 +1957,7 @@
+ PED_ASSERT (sizeof (AtariRawPartition) == 12);
+ PED_ASSERT (sizeof (AtariRawTable) == 512);
+ /* GNU Libc doesn't support NULL instead of the locale name */
+- PED_ASSERT ((atr_c_locale = newlocale(LC_ALL_MASK, "C", NULL)) != NULL);
++ atr_c_locale = newlocale(LC_ALL_MASK, "C", NULL);
+
+ ped_disk_type_register (&atari_disk_type);
+ }
diff --git a/sys-block/parted/parted-3.3.ebuild b/sys-block/parted/parted-3.3-r1.ebuild
index 1945a7562545..4f2c019b732c 100644
--- a/sys-block/parted/parted-3.3.ebuild
+++ b/sys-block/parted/parted-3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,6 +31,7 @@ DEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ "${FILESDIR}"/${PN}-3.3-atari.patch
)
src_prepare() {