summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/whdd')
-rw-r--r--sys-block/whdd/Manifest3
-rw-r--r--sys-block/whdd/metadata.xml6
-rw-r--r--sys-block/whdd/whdd-2.2.ebuild27
-rw-r--r--sys-block/whdd/whdd-3.0.1-r2.ebuild (renamed from sys-block/whdd/whdd-3.0.ebuild)20
-rw-r--r--sys-block/whdd/whdd-9999.ebuild34
5 files changed, 15 insertions, 75 deletions
diff --git a/sys-block/whdd/Manifest b/sys-block/whdd/Manifest
index b42987e174f4..c2bc70e91df6 100644
--- a/sys-block/whdd/Manifest
+++ b/sys-block/whdd/Manifest
@@ -1,2 +1 @@
-DIST whdd-2.2.tar.gz 33317 BLAKE2B 0f0f6a36c37ec8b0df538fe6c353fc14bfd1f2cecbe2b6c0c94727d4a417c1cba3e96ecd323d52a60a67b8f169ecde2e50196db090657f496cd7d46d37fb7079 SHA512 ab30c1e418cb7ba9881b1a91b99d0b1d5389172c4d5802be69d98cb9c16f1282ff7808e2b40bb937987a9d3ad9fa7f20e630d19307eb0aa1090cff531a904d4a
-DIST whdd-3.0.tar.gz 45865 BLAKE2B 788ae197c5607f9044f68523336786eacf40eca382d531c590d3b45ec3710c5ea66740f8f5a9750a9746d78a0c6b7e9c77153345ef39cff962a6b2652f3f5d80 SHA512 f53888383dc0ed4158c13a064a2cd45e8e312b389bb79c1bfc9ce86c8a61a195fe5003821c868715316eeaba7ee5bcb387324fb6577af7f875679789cd5af5d7
+DIST whdd-3.0.1-rel.tar.gz 45657 BLAKE2B 9730e61580359c95fc3e3d23540f3b10e75b476e634cce3be744b8849193f43f968f227bdbd25a0c643106c1343b27070c8b51f33278e902ab54991a05eee021 SHA512 6d5d8dad7537118a5915a29a549e18595da1b6ba031f0ca661805ad0033fd48f32804eb307f67e7b31d6002e708ae578a32aff366f3e610ab36b25f0a4e50803
diff --git a/sys-block/whdd/metadata.xml b/sys-block/whdd/metadata.xml
index 6cf10586a8f4..fdad2c16cfd6 100644
--- a/sys-block/whdd/metadata.xml
+++ b/sys-block/whdd/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>andrey_utkin@gentoo.org</email>
- <name>Andrey Utkin</name>
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
</maintainer>
<upstream>
<remote-id type="github">whdd/whdd</remote-id>
diff --git a/sys-block/whdd/whdd-2.2.ebuild b/sys-block/whdd/whdd-2.2.ebuild
deleted file mode 100644
index 8f7afc6967d3..000000000000
--- a/sys-block/whdd/whdd-2.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Diagnostic and recovery tool for block devices"
-HOMEPAGE="https://whdd.github.io"
-SRC_URI="https://github.com/krieger-od/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-util/dialog:=
- sys-libs/ncurses:0[unicode]"
-RDEPEND="${DEPEND}
- sys-apps/smartmontools"
-
-src_unpack() {
- default
- mv krieger-od-${PN}-* ${P}
- echo ${PV} > "${S}"/VERSION || die
-}
diff --git a/sys-block/whdd/whdd-3.0.ebuild b/sys-block/whdd/whdd-3.0.1-r2.ebuild
index 967ab1dc5447..fdadb1a4f8d4 100644
--- a/sys-block/whdd/whdd-3.0.ebuild
+++ b/sys-block/whdd/whdd-3.0.1-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Diagnostic and recovery tool for block devices"
HOMEPAGE="https://whdd.github.io"
@@ -13,18 +13,15 @@ then
EGIT_REPO_URI="https://github.com/${PN}/${PN}"
inherit git-r3
else
- SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- inherit vcs-snapshot
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-rel.tar.gz"
+ KEYWORDS="amd64 ~riscv ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
-DEPEND="
- dev-util/dialog:=
- sys-libs/ncurses:0=[unicode]"
+DEPEND="dev-util/dialog:=
+ sys-libs/ncurses:=[unicode(+)]"
RDEPEND="${DEPEND}
sys-apps/smartmontools"
@@ -32,3 +29,8 @@ src_compile() {
tc-export CC
default
}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+}
diff --git a/sys-block/whdd/whdd-9999.ebuild b/sys-block/whdd/whdd-9999.ebuild
deleted file mode 100644
index 967ab1dc5447..000000000000
--- a/sys-block/whdd/whdd-9999.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Diagnostic and recovery tool for block devices"
-HOMEPAGE="https://whdd.github.io"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == 9999 ]]
-then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- inherit vcs-snapshot
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- dev-util/dialog:=
- sys-libs/ncurses:0=[unicode]"
-RDEPEND="${DEPEND}
- sys-apps/smartmontools"
-
-src_compile() {
- tc-export CC
- default
-}