summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/rts_pstor/Manifest1
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch53
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch29
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-vmalloc.patch44
-rw-r--r--sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild38
5 files changed, 0 insertions, 165 deletions
diff --git a/sys-block/rts_pstor/Manifest b/sys-block/rts_pstor/Manifest
index 640713b749b2..283cf39a5233 100644
--- a/sys-block/rts_pstor/Manifest
+++ b/sys-block/rts_pstor/Manifest
@@ -1,2 +1 @@
-DIST rts_pstor-1.10.tar.bz2 79549 BLAKE2B 6ed1a31c46920f30b16c3cd4bda9978bffe40c2f88fdd2d63ef128d3a4ce22a6850846e4f5f1bf55200ed03a227a61bfcaefec4abdf598a43c8a7d8ca2991280 SHA512 26d29ccda55672adab8b96a8318e240d0c9d50ebf614853284cf218058c5788cc83b818ce118ac313c0ce6a67aef8ad13d93ed26212db7e05db51b8a7860b48d
DIST rts_pstor-1.10_p20160103.tar.gz 108102 BLAKE2B 9cbca345211f7c99c6d9cf71b0ed207a4c911569eee6c63bfbe15c094be08f64c4550f04d9df688969f43564b2ff6a91d5cc72b8ab281cfdffb6884688b354de SHA512 d802a52b1e2da447a218472e77ca6ecc56e3b3767e3eb8daf634152675171c79c86e3b5ca9654b67cf32f63740c347bf7ecee5a1d20eb1c15a3a2ad3e9774311
diff --git a/sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch b/sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch
deleted file mode 100644
index 0070549b88d8..000000000000
--- a/sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- rts_pstor.a/rtsx.c 2013-07-03 05:39:26.316723407 +0530
-+++ rts_pstor.b/rtsx.c 2013-07-03 05:28:28.584882761 +0530
-@@ -135,38 +135,18 @@
-
-
- #undef SPRINTF
--#define SPRINTF(args...) \
-- do { if (pos < buffer+length) pos += sprintf(pos, ## args); } while (0)
-+#define SPRINTF(args...) seq_printf(m, ##args)
-
--static int proc_info (struct Scsi_Host *host, char *buffer,
-- char **start, off_t offset, int length, int inout)
-+static int show_info(struct seq_file *m, struct Scsi_Host *host)
- {
-- char *pos = buffer;
--
--
-- if (inout)
-- return length;
--
-
- SPRINTF(" Host scsi%d: %s\n", host->host_no, CR_DRIVER_NAME);
--
-
- SPRINTF(" Vendor: Realtek Corp.\n");
- SPRINTF(" Product: PCIE Card Reader\n");
- SPRINTF(" Version: %s\n", DRIVER_VERSION);
- SPRINTF(" Build: %s\n", DRIVER_MAKE_TIME);
--
-- /*
-- * Calculate start of next buffer, and return value.
-- */
-- *start = buffer + offset;
--
-- if ((pos - buffer) < offset)
-- return (0);
-- else if ((pos - buffer - offset) < length)
-- return (pos - buffer - offset);
-- else
-- return (length);
-+ return 0;
- }
-
-
-@@ -272,7 +252,7 @@
-
- .name = CR_DRIVER_NAME,
- .proc_name = CR_DRIVER_NAME,
-- .proc_info = proc_info,
-+ .show_info = show_info,
- .info = host_info,
-
-
diff --git a/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch b/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch
deleted file mode 100644
index 797b1088f31b..000000000000
--- a/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- rts_pstor.a/rtsx.c 2011-01-11 14:41:07.000000000 +0530
-+++ rts_pstor.b/rtsx.c 2013-05-29 00:39:11.319267655 +0530
-@@ -913,7 +913,7 @@
- chip->s3_pwr_off_delay = 1000;
- }
-
--static int __devinit rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
-+static int rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
- {
- struct Scsi_Host *host;
- struct rtsx_dev *dev;
-@@ -1077,7 +1077,7 @@
- }
-
-
--static void __devexit rtsx_remove(struct pci_dev *pci)
-+static void rtsx_remove(struct pci_dev *pci)
- {
- struct rtsx_dev *dev = (struct rtsx_dev *)pci_get_drvdata(pci);
-
-@@ -1104,7 +1104,7 @@
- .name = CR_DRIVER_NAME,
- .id_table = rtsx_ids,
- .probe = rtsx_probe,
-- .remove = __devexit_p(rtsx_remove),
-+ .remove = rtsx_remove,
- #ifdef CONFIG_PM
- .suspend = rtsx_suspend,
- .resume = rtsx_resume,
diff --git a/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch b/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch
deleted file mode 100644
index 3b3f4beb885d..000000000000
--- a/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur rts_pstor.a/ms.c rts_pstor.b/ms.c
---- rts_pstor.a/ms.c 2011-01-11 04:11:07.000000000 -0500
-+++ rts_pstor.b/ms.c 2015-09-17 01:28:41.816067799 -0400
-@@ -23,6 +23,7 @@
- #include <linux/blkdev.h>
- #include <linux/kthread.h>
- #include <linux/sched.h>
-+#include <linux/vmalloc.h>
-
- #include "rtsx.h"
- #include "rtsx_transport.h"
-diff -Naur rts_pstor.a/rtsx_chip.c rts_pstor.b/rtsx_chip.c
---- rts_pstor.a/rtsx_chip.c 2011-01-11 04:11:07.000000000 -0500
-+++ rts_pstor.b/rtsx_chip.c 2015-09-17 01:28:13.680536901 -0400
-@@ -24,6 +24,7 @@
- #include <linux/kthread.h>
- #include <linux/sched.h>
- #include <linux/workqueue.h>
-+#include <linux/vmalloc.h>
-
- #include "rtsx.h"
- #include "rtsx_transport.h"
-diff -Naur rts_pstor.a/rtsx_scsi.c rts_pstor.b/rtsx_scsi.c
---- rts_pstor.a/rtsx_scsi.c 2011-01-11 04:11:07.000000000 -0500
-+++ rts_pstor.b/rtsx_scsi.c 2015-09-17 01:28:42.688053259 -0400
-@@ -23,6 +23,7 @@
- #include <linux/blkdev.h>
- #include <linux/kthread.h>
- #include <linux/sched.h>
-+#include <linux/vmalloc.h>
-
- #include "rtsx.h"
- #include "rtsx_transport.h"
-diff -Naur rts_pstor.a/xd.c rts_pstor.b/xd.c
---- rts_pstor.a/xd.c 2011-01-11 04:11:07.000000000 -0500
-+++ rts_pstor.b/xd.c 2015-09-17 01:28:42.689053242 -0400
-@@ -23,6 +23,7 @@
- #include <linux/blkdev.h>
- #include <linux/kthread.h>
- #include <linux/sched.h>
-+#include <linux/vmalloc.h>
-
- #include "rtsx.h"
- #include "rtsx_transport.h"
diff --git a/sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild b/sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild
deleted file mode 100644
index 82466767b794..000000000000
--- a/sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit linux-mod
-
-DESCRIPTION="PCIE RTS5209 card reader driver for Linux"
-HOMEPAGE="http://www.realtek.com.tw/Downloads/downloadsView.aspx?PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3"
-SRC_URI="https://dev.gentoo.org/~vikraman/distfiles/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-MODULE_NAMES="rts_pstor(misc/drivers/scsi)"
-BUILD_TARGETS="default"
-
-src_prepare() {
- sed -e 's/\/lib\/modules\/\$(shell uname -r)\/build\//\$(KERNELDIR)/g' \
- -i Makefile || die "Sed failed!"
- ([ ${KV_MAJOR} -gt 3 ] || ([ ${KV_MAJOR} -eq 3 ] && [ ${KV_MINOR} -ge 8 ])) \
- && epatch "${FILESDIR}/${PN}-linux-3.8.patch"
- ([ ${KV_MAJOR} -gt 3 ] || ([ ${KV_MAJOR} -eq 3 ] && [ ${KV_MINOR} -ge 10 ])) \
- && epatch "${FILESDIR}/${PN}-linux-3.10.patch"
- epatch "${FILESDIR}/${PN}-vmalloc.patch"
-}
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
-}