summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/woeusb')
-rw-r--r--sys-boot/woeusb/Manifest1
-rw-r--r--sys-boot/woeusb/woeusb-3.3.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-boot/woeusb/Manifest b/sys-boot/woeusb/Manifest
index 7a57f4c7ff7d..d7077238214c 100644
--- a/sys-boot/woeusb/Manifest
+++ b/sys-boot/woeusb/Manifest
@@ -1,2 +1,3 @@
DIST woeusb-3.1.5.tar.gz 399712 BLAKE2B d52b29249af680577299a02cb9a2c1436aef73a0240bff2525c494657c197a2fc0709e0ff6f35eb5d18592145347af284a998deacecff37effd95b75ab13bc9a SHA512 5cf4eb45b126d71bcb376148383faf9713bc06ec4ee3ccc2dfa6528d9fba382bceaae2cdd47f2d8ba775dad1ca8e6258af40fc6362336927894398193600c965
DIST woeusb-3.2.12.tar.gz 386189 BLAKE2B 53629a185d0b8ff55cb2e60eaa6cb8f9e106d3f5b24f57cf8f777dbf5b9a1e43ed423e53e4710acf9ac5ce3171da7dbfcd40b5b3f297b0db240e7c0f9a687fc0 SHA512 9a4e20003970a3313b080bde9a534fb1724382555281aa510092a3698622dae46f22483ff8968903b5685e00ebfb454718de6db7f3c61c4a2e122c961bfc270f
+DIST woeusb-3.3.0.tar.gz 386251 BLAKE2B 9767fc3ab3ae438ff126c05a197cb41550704b93f3b508ad88b7a39c74777fdd863794970ebc839f79f8b2f1da9f6041bb355783ec1040e31814fead8185439c SHA512 8cac015df2309e4978f38adae9b9da04d896301f8d9d971d3d21801b24c3287d7d405bc4b2b1e0ff285497b5777462eb8cd6ce7dce079daf49b4d5d313a449a3
diff --git a/sys-boot/woeusb/woeusb-3.3.0.ebuild b/sys-boot/woeusb/woeusb-3.3.0.ebuild
new file mode 100644
index 000000000000..81c09abcf2ef
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-3.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/slacka/WoeUSB"
+SRC_URI="https://github.com/slacka/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/dosfstools
+ sys-fs/ntfs3g
+ sys-boot/grub:2[grub_platforms_pc]
+ !minimal? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/WoeUSB-${PV}"
+
+src_prepare() {
+ default
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${PV}/" || die
+ if ! use minimal; then
+ setup-wxwidgets
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ ! use minimal && default
+}
+
+src_compile() {
+ ! use minimal && default
+}
+
+src_test() {
+ ! use minimal && default
+}
+
+src_install() {
+ if use minimal; then
+ dosbin src/woeusb
+ einstalldocs
+ else
+ default
+ fi
+}