summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/quik/Manifest1
-rw-r--r--sys-boot/quik/files/headers.patch33
-rw-r--r--sys-boot/quik/files/md-fix.diff11
-rw-r--r--sys-boot/quik/metadata.xml8
-rw-r--r--sys-boot/quik/quik-2.1.6.ebuild45
5 files changed, 0 insertions, 98 deletions
diff --git a/sys-boot/quik/Manifest b/sys-boot/quik/Manifest
deleted file mode 100644
index dd6faab8afc3..000000000000
--- a/sys-boot/quik/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST quik-2.1-6.ydl4.src.rpm 91961 BLAKE2B 3398e2278e7700e8da6a68fec135006959eda47663bf0403c041710b3edfd5cc7243a79f84464f0bf8ae91e025df5407e159710bd3ee693d9513f04dbf926fee SHA512 92cdea02afd5053fb51b390e79f4d2d404691be5de9ea3d9c88739fc4fa993b68a017be10ff1b5fa359f8c5493f34d0d743975f5ce99525bdaf5921b0146aa63
diff --git a/sys-boot/quik/files/headers.patch b/sys-boot/quik/files/headers.patch
deleted file mode 100644
index eccfba698e17..000000000000
--- a/sys-boot/quik/files/headers.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- util/elfextract.c.bak 2006-12-04 23:08:33.000000000 -0500
-+++ util/elfextract.c 2006-12-04 23:08:45.000000000 -0500
-@@ -6,7 +6,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #define __KERNEL__
--#include <linux/elf.h>
-+#include <elf.h>
-
- FILE *fi, *fo;
- char *ni, *no;
---- second/quik.h.bak 2006-12-04 23:10:08.000000000 -0500
-+++ second/quik.h 2006-12-04 23:10:12.000000000 -0500
-@@ -26,7 +26,7 @@
- int tolower(int c);
- int stricmp(const char *s1, const char *s2);
- int strncmp(const char * cs,const char * ct,size_t count);
--int strlen(const char *s1);
-+// int strlen(const char *s1);
- char *strcpy(char * dest,const char *src);
- char *strncpy(char * dest,const char *src,size_t count);
- char *strchr(const char * s, int c);
---- second/misc.c.bak 2010-02-09 22:18:47.000000000 -0500
-+++ second/misc.c 2010-02-09 22:18:52.000000000 -0500
-@@ -11,7 +11,7 @@
- */
- #include <linux/kernel.h>
-
--#include <asm/page.h>
-+// #include <asm/page.h>
-
- #include <sys/types.h>
- #include "setjmp.h"
diff --git a/sys-boot/quik/files/md-fix.diff b/sys-boot/quik/files/md-fix.diff
deleted file mode 100644
index 2319397d93f1..000000000000
--- a/sys-boot/quik/files/md-fix.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/quik_md.h.bak 2005-05-27 00:42:36.000000000 +1000
-+++ include/quik_md.h 2005-05-27 00:42:43.000000000 +1000
-@@ -88,8 +88,6 @@
- #define BOOTDEV(dev,i) ((dev)->devs[(i)]->bootdev)
- #define SPART(dev,i) ((dev)->devs[(i)]->spart)
-
--dev_info_t * new_dev_info (unsigned char);
--void free_dev_info (dev_info_t *);
- int md_get_version (int);
- mdev_info_t * md_get_info (const char *);
-
diff --git a/sys-boot/quik/metadata.xml b/sys-boot/quik/metadata.xml
deleted file mode 100644
index 5eb05198076b..000000000000
--- a/sys-boot/quik/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>ppc@gentoo.org</email>
- <name>Gentoo Linux PowerPC Development</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-boot/quik/quik-2.1.6.ebuild b/sys-boot/quik/quik-2.1.6.ebuild
deleted file mode 100644
index 1a0ca2e1926f..000000000000
--- a/sys-boot/quik/quik-2.1.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit toolchain-funcs mount-boot eutils
-
-MY_PV=${PV%.*}-${PV#*.*.}
-
-HOMEPAGE="http://penguinppc.org/bootloaders/quik/"
-DESCRIPTION="OldWorld PowerMac Bootloader"
-SRC_URI="http://www.shiner.info/files/Yellow%20Dog%20Linux%204/quik/quik-${MY_PV}.ydl4.src.rpm"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ppc"
-IUSE=""
-
-DEPEND="app-arch/rpm2targz"
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- cd "${WORKDIR}"
- rpm2targz "${DISTDIR}/quik-${MY_PV}.ydl4.src.rpm"
- tar -xzf "${WORKDIR}/quik-${MY_PV}.ydl4.src.tar.gz" || die
- tar -xzf "${WORKDIR}/quik_2.1.orig.tar.gz" || die
-
- cd "${WORKDIR}/quik-2.1"
- epatch "${WORKDIR}/quik_2.1-6.diff.gz"
- epatch "${FILESDIR}/md-fix.diff"
- epatch "${FILESDIR}/headers.patch"
-}
-
-src_compile() {
- cd "${WORKDIR}/quik-2.1"
- emake || die
-}
-
-src_install() {
- cd "${WORKDIR}/quik-2.1"
- DESTDIR=${D} make install
- prepman /usr
-}