summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/os-prober/os-prober-1.78.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-boot/os-prober/os-prober-1.78.ebuild b/sys-boot/os-prober/os-prober-1.78.ebuild
index 6b81b75a08cc..93272217dfe7 100644
--- a/sys-boot/os-prober/os-prober-1.78.ebuild
+++ b/sys-boot/os-prober/os-prober-1.78.ebuild
@@ -68,7 +68,9 @@ src_install() {
exeinto /usr/lib/${dir}
doexe ${dir}/common/*
if [[ -d ${dir}/${debarch} ]]; then
- doexe ${dir}/${debarch}/*
+ for exe in ${dir}/${debarch}/*; do
+ [[ ! -d "${exe}" ]] && doexe "${exe}"
+ done
fi
if [[ -d ${dir}/${debarch}/efi ]]; then
exeinto /usr/lib/${dir}/efi