summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/gearmand')
-rw-r--r--sys-cluster/gearmand/files/gearmand-0.34-stdbool-h.patch26
-rw-r--r--sys-cluster/gearmand/gearmand-0.34-r1.ebuild25
-rw-r--r--sys-cluster/gearmand/metadata.xml4
3 files changed, 43 insertions, 12 deletions
diff --git a/sys-cluster/gearmand/files/gearmand-0.34-stdbool-h.patch b/sys-cluster/gearmand/files/gearmand-0.34-stdbool-h.patch
new file mode 100644
index 000000000000..37d2db62741d
--- /dev/null
+++ b/sys-cluster/gearmand/files/gearmand-0.34-stdbool-h.patch
@@ -0,0 +1,26 @@
+Ignore configure checks and include stdbool.h
+unconditionally, we're in 2016.
+
+--- gearmand-0.34/libhostile/called.c
++++ gearmand-0.34/libhostile/called.c
+@@ -41,6 +41,7 @@
+ #include <assert.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <stdbool.h>
+
+ __thread bool is_called_= false;
+ static __thread char** unique_ptr= NULL;
+--- gearmand-0.34/libhostile/called.h
++++ gearmand-0.34/libhostile/called.h
+@@ -36,9 +36,7 @@
+
+ #pragma once
+
+-#ifdef HAVE_STDBOOL_H
+-# include <stdbool.h>
+-#endif
++#include <stdbool.h>
+
+ bool is_called(void);
+ void set_called();
diff --git a/sys-cluster/gearmand/gearmand-0.34-r1.ebuild b/sys-cluster/gearmand/gearmand-0.34-r1.ebuild
index 54ce1120ba24..41205c55d347 100644
--- a/sys-cluster/gearmand/gearmand-0.34-r1.ebuild
+++ b/sys-cluster/gearmand/gearmand-0.34-r1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit flag-o-matic libtool user autotools-utils
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils flag-o-matic libtool user
DESCRIPTION="Generic framework to farm out work to other machines"
HOMEPAGE="http://www.gearman.org/"
@@ -13,31 +15,38 @@ SRC_URI="https://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet postgres"
+IUSE="debug tcmalloc +memcache sqlite tokyocabinet postgres"
RDEPEND="dev-libs/libevent
>=dev-libs/boost-1.39:=[threads(+)]
|| ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
tcmalloc? ( dev-util/google-perftools )
memcache? ( >=dev-libs/libmemcached-0.47 )
- drizzle? ( dev-db/drizzle )
sqlite? ( dev-db/sqlite:3 )
tokyocabinet? ( dev-db/tokyocabinet )
- postgres? ( >=dev-db/postgresql-9.0 )"
+ postgres? ( >=dev-db/postgresql-9.0:* )"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+ >=sys-devel/boost-m4-0.4_p20160328"
pkg_setup() {
enewuser gearmand -1 -1 /dev/null nogroup
}
+src_prepare() {
+ # fixes bug 574558, which is due to an outdated bundled boost.m4
+ rm m4/boost.m4 || die
+ sed -i -e 's/AM_INIT_AUTOMAKE.*//g' m4/pandora_canonical.m4 || die
+ epatch -p1 "${FILESDIR}/${P}-stdbool-h.patch"
+ autotools-utils_src_prepare
+}
+
src_configure() {
local myeconfargs=(
- $(use_enable drizzle libdrizzle)
$(use_enable memcache libmemcached)
- $(use_enable postgres libpq)
$(use_enable tcmalloc)
$(use_enable tokyocabinet libtokyocabinet)
+ $(use_with postgres postgresql)
$(use_with sqlite sqlite3)
--disable-mtmalloc
--disable-static
diff --git a/sys-cluster/gearmand/metadata.xml b/sys-cluster/gearmand/metadata.xml
index cc650702091f..21a9a92af98e 100644
--- a/sys-cluster/gearmand/metadata.xml
+++ b/sys-cluster/gearmand/metadata.xml
@@ -17,10 +17,6 @@
Support memcache daemon (via <pkg>dev-libs/libmemcached</pkg>)
for the queue storage.
</flag>
- <flag name="drizzle">
- Support <pkg>dev-db/libdrizzle</pkg> for the queue storage. This
- also adds support for MySQL storage.
- </flag>
<flag name="tokyocabinet">
Support <pkg>dev-db/tokyocabinet</pkg> for the queue storage.
</flag>