summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bc/bc-1.06.95-r1.ebuild')
-rw-r--r--sys-devel/bc/bc-1.06.95-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sys-devel/bc/bc-1.06.95-r1.ebuild b/sys-devel/bc/bc-1.06.95-r1.ebuild
deleted file mode 100644
index 5ae9bc3006cd..000000000000
--- a/sys-devel/bc/bc-1.06.95-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Handy console-based calculator utility"
-HOMEPAGE="https://www.gnu.org/software/bc/bc.html"
-SRC_URI="mirror://gnu-alpha/bc/${P}.tar.bz2
- mirror://gnu/bc/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libedit readline static"
-
-RDEPEND="readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- libedit? ( dev-libs/libedit )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-void_uninitialized.patch #349339
-}
-
-src_configure() {
- export CONFIG_SHELL=${BASH}
-
- local myconf
- if use readline ; then
- myconf="--with-readline --without-libedit"
- elif use libedit ; then
- myconf="--without-readline --with-libedit"
- else
- myconf="--without-readline --without-libedit"
- fi
- use static && append-ldflags -static
- econf ${myconf}
-
- # Do not regen docs -- configure produces a small fragment that includes
- # the version info which causes all pages to regen (newer file). #554774
- touch -r doc doc/*
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS FAQ NEWS README ChangeLog
-}