summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bc')
-rw-r--r--sys-devel/bc/bc-1.07.1-r2.ebuild3
-rw-r--r--sys-devel/bc/files/bc-1.07.1-use-system-bc.patch16
2 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/bc/bc-1.07.1-r2.ebuild b/sys-devel/bc/bc-1.07.1-r2.ebuild
index 5a7d1afa3a78..99044d02af94 100644
--- a/sys-devel/bc/bc-1.07.1-r2.ebuild
+++ b/sys-devel/bc/bc-1.07.1-r2.ebuild
@@ -35,6 +35,9 @@ PATCHES=(
src_prepare() {
default
+ # Avoid bad build tool usage when cross-compiling. #627126
+ tc-is-cross-compiler && eapply "${FILESDIR}/${PN}-1.07.1-use-system-bc.patch"
+
# A patch to make this into a configure option has been sent upstream,
# but lets avoid regenerating all the autotools just for this.
if use forced-sandbox ; then
diff --git a/sys-devel/bc/files/bc-1.07.1-use-system-bc.patch b/sys-devel/bc/files/bc-1.07.1-use-system-bc.patch
new file mode 100644
index 000000000000..03ccb68c0836
--- /dev/null
+++ b/sys-devel/bc/files/bc-1.07.1-use-system-bc.patch
@@ -0,0 +1,16 @@
+when cross-compiling, the local fbc binary won't work. use the system
+bc instead as the demands of the .b script are simple enough.
+
+https://bugs.gentoo.org/627126
+
+--- a/bc/Makefile.in
++++ b/bc/Makefile.in
+@@ -628,7 +628,7 @@ libmath.h: libmath.b $(fbcOBJ) $(LIBBC)
+ echo '{0}' > libmath.h
+ $(MAKE) global.o
+ $(LINK) -o fbc $(fbcOBJ) global.o $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
+- ./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
++ bc -c $(srcdir)/libmath.b </dev/null >libmath.h
+ $(srcdir)/fix-libmath_h
+ rm -f ./fbc ./global.o
+ sbc.o: sbc.c