summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-hppa64/binutils-hppa64-2.29.1-r1.ebuild')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.29.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.29.1-r1.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.29.1-r1.ebuild
new file mode 100644
index 000000000000..1e3b4a3273a7
--- /dev/null
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.29.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+export CTARGET=hppa64-${CHOST#*-}
+
+PATCHVER="2"
+ELF2FLT_VER=""
+inherit toolchain-binutils
+
+DESCRIPTION="binutils package for building 64bit kernels on HPPA"
+
+KEYWORDS="-* ~hppa"
+
+# 66_all_binutils-2.22-warn-textrel.patch fails to apply with
+# patch-2.5.9, so require a version that for sure works
+DEPEND+=" >=sys-devel/patch-2.6.1"
+
+src_install() {
+ toolchain-binutils_src_install
+
+ # tweak the default fake list a little bit
+ cd "${D}"/etc/env.d/binutils
+ sed -i '/FAKE_TARGETS=/s:"$: hppa64-linux":' ${CTARGET}-${BVER} || die
+}