summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.5.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 1fee0007face..e9938c627396 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -8,3 +8,5 @@ DIST bison-3.4.1-patches-01.tar.xz 10812 BLAKE2B 81311c4de0e70e5ca5861e36918be13
DIST bison-3.4.1.tar.xz 2198020 BLAKE2B 03369f92959061fd780fcde38d62e81f433ec7c0e6632ddf27bfb48607fdd510aa8e2e9fefd7e130b84972e168ff0762a7bed4f7a817be36c848ec6562357d2d SHA512 544d66bf11c55a69fad613bea429667c587fb0c3774f6894df81cb3c7931a554f79e6b71d6a6e9109e164e524c632127c967877f71328cd0b69a683d29ed128d
DIST bison-3.4.2-patches-01.tar.xz 11152 BLAKE2B a0d0423e034cfa1dc45a542c05667a8226b535e82c260f638b67f4cf0f693b55b531bf310ed2e701ed7cc8b30f4b9ba9de61dcfcc64428fed38c9d528976b4bd SHA512 14341c52bf53d9fa58da0818626312b199ad1c14b2e0180589d6713d79caa6206070826e0ea65901cee0f6bf3122a7a9f8dad75a6c7d31cb11a31136e7d5a325
DIST bison-3.4.2.tar.xz 2240532 BLAKE2B fb3d90dc3f21075069684e5d9f8d6982353d909b8c62c4d9925a22319c9f486a4ad7e2629a8932449a3444580ed701357c326aa7cd778a68f66f8eeae70cdac1 SHA512 00d2b37187b93100ec4b220ce2752d12ccf68f9d0d39b380d375d36dd8a22aa1d6e60156918f95e4493f9531c5d42d8fad38fd807307b491c1ca7ca4177823d9
+DIST bison-3.5-patches-01.tar.xz 9220 BLAKE2B 41ccdc164960e56722143b579a679a2699905c2ee2779fc882bb56871aa0a1d0fb530cf8249c354375bc2d61285754b257262191446524c8ec5b0cff0cd973ec SHA512 28b108540cad75dd6aec9cd0a17320a44e7bcd305faea9d35f5b38b0672a3646cacce3c45f5c1528560081280ed617f98fa467ad2479e0df108e0020ba029180
+DIST bison-3.5.tar.xz 2341024 BLAKE2B 1c0af1cc12cd1e4d264adebb5c043b8ac510cd613a2a22c4232d88b077eecac7d1a36c07a4fb3d425cd1907b830f53862be570bbca6faaf0ef43981d6fecd1d3 SHA512 309ba77cfbf5d5ca697f522ac18ca9b55a1ec4e690b87220c97ffb1137b8bd8b22aa14c111166f0f4bf001e88f4bcbfd0583bc09810c246f0dc60fd6e8478950
diff --git a/sys-devel/bison/bison-3.5.ebuild b/sys-devel/bison/bison-3.5.ebuild
new file mode 100644
index 000000000000..fed9c05eb312
--- /dev/null
+++ b/sys-devel/bison/bison-3.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.5-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${PATCHES}
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.5-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.5-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}