summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.0.5-r1.ebuild89
2 files changed, 0 insertions, 91 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 66f48714aed5..f3d4c4646ace 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -1,5 +1,3 @@
-DIST bison-3.0.5-patches-1.1.tar.xz 5188 BLAKE2B 437a202cfc2431a5fe9a31ea6bcce5978d5a6ca5e812f3a45928a67aa78ec7c93327e0520516aa5f79a0d7c395e7b959f22d3f2f962eab5a5b826d3f9816786a SHA512 54371d28f3d0ec7a2709684030f4f008cff4cb1a74ba30586615caace5417d4d475a7453ba956d8d10ee819391779d74725c203412339388d4131ddebd46f93d
-DIST bison-3.0.5.tar.xz 1954868 BLAKE2B b6a8b426304f414c1b7601e75dcae8a63847b71361fba2538ad5cc52f3527fe464b066add670a236d5e1d2aff65bbe7a99c282ee3c72a0bfaa498d40e3a50398 SHA512 00b448db8abe91b07e32ff5273c6617bc1350d806f92073a9472f4c2f0de5d22c152795674171b74f2eb9eff8d36f8173b82dacb215601bb071ae39404d4a8a2
DIST bison-3.1-patches-1.0.tar.xz 7268 BLAKE2B 9195c00be1706664762598926913cd8fc18a32a6ae6ae4ec58748d5e8fc4877f63258db51cbe3bf84f3345ea0fc7c27d2e1190632c529615d9e6922baef74915 SHA512 5569b7901b40ea01eb7bccdc1b090207bc1ea6c50d144b561b2725ae79f3bcd51e7ea4e8ea37b60ea50ff4882e82110a07986cba1d2397a0333e7e01ae466e79
DIST bison-3.1.tar.xz 1990536 BLAKE2B 6223642f2934927ca118410e2655f7c677bb1d3d981875ca2224f5aa344a43efbbbea34e79dff94ea489853e505b1d7f5920f4d159d1464ce61d8956ca0401ad SHA512 2a8e217ffb55ed5b1fcc989377ac348a066e62b8a4b0b0da40c3c7202f3ea487b2aab6a704a10b48d2d17673be0e22f6ff1be91fc05c4e0a57969b42a59d0152
DIST bison-3.2.1-patches-01.tar.xz 8232 BLAKE2B 84be6854bc26cdf1308c466257ba03b0a8cfffd668332454a59311239347f6bd83fb53a742ad85d06b607c45c9f0d1498a53fca9cb82595406f760ce362d3761 SHA512 b0a5b37bd0e9bf09ef742f2b3b4b06d0954a66f411f87975e023468b8705dc31e58bd365cb501a1c53777cf98c05b5473bf12f034a55b8b99066202a382d196d
diff --git a/sys-devel/bison/bison-3.0.5-r1.ebuild b/sys-devel/bison/bison-3.0.5-r1.ebuild
deleted file mode 100644
index 8474dc7fffb2..000000000000
--- a/sys-devel/bison/bison-3.0.5-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic
-
-DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
-HOMEPAGE="https://www.gnu.org/software/bison/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- https://dev.gentoo.org/~whissi/dist/bison/${P}-patches-1.1.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples nls static test"
-
-RDEPEND=">=sys-devel/m4-1.4.16"
-DEPEND="${RDEPEND}
- sys-devel/flex
- examples? ( dev-lang/perl )
- nls? ( sys-devel/gettext )
- test? ( dev-lang/perl )"
-
-DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
-
-PATCHES=(
- "${WORKDIR}"/patches/${P}-optional-perl.patch #538300
- "${WORKDIR}"/patches/${P}-avoid_autoreconf.patch
-)
-
-src_prepare() {
- # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
- touch -r configure.ac old.configure.ac || die
- touch -r configure old.configure || die
-
- default
-
- # Restore date after patching
- touch -r old.configure.ac configure.ac || die
- touch -r old.configure configure || die
-
- # The makefiles make the man page depend on the configure script
- # which we patched above. Touch it to prevent regeneration.
- touch doc/bison.1 || die #548778 #538300#9
-
- # Avoid regenerating the info page when the timezone is diff. #574492
- sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- local myeconfargs=(
- --docdir='$(datarootdir)'/doc/${PF}
- $(use_enable examples)
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- # This one is installed by dev-util/yacc
- mv "${ED%/}"/usr/bin/yacc{,.bison} || die
- mv "${ED%/}"/usr/share/man/man1/yacc{,.bison}.1 || die
-
- # We do not need liby.a
- rm -r "${ED%/}"/usr/lib* || die
-
- # Move to documentation directory and leave compressing for EAPI>=4
- mv "${ED%/}"/usr/share/${PN}/README "${ED%/}"/usr/share/doc/${PF}/README.data
-}
-
-pkg_postinst() {
- local f="${EROOT%/}/usr/bin/yacc"
- if [[ ! -e ${f} ]] ; then
- ln -s yacc.bison "${f}"
- fi
-}
-
-pkg_postrm() {
- # clean up the dead symlink when we get unmerged #377469
- local f="${EROOT%/}/usr/bin/yacc"
- if [[ -L ${f} && ! -e ${f} ]] ; then
- rm -f "${f}"
- fi
-}