summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.2.2.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 5ffc8e248ed7..166e908f9855 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -5,4 +5,6 @@ DIST bison-3.1.tar.xz 1990536 BLAKE2B 6223642f2934927ca118410e2655f7c677bb1d3d98
DIST bison-3.2-patches-01.tar.xz 7696 BLAKE2B 5a83c118204173a8c264a1e9ca929612c8c1cceea40c2f45057ed053c34087b0dbef0bd25d299e9c928c192a68d55b83687c54cf3cab7c28ed557b2eac12ad5a SHA512 5fe6d40ac1f388764989653a8f1289d1368b75952ffae271e015853dc5c70a85430573a3ab261cca8d498d87f590b1257c6e72a7adb72a51a5f3e3bc56d87ec2
DIST bison-3.2.1-patches-01.tar.xz 8232 BLAKE2B 84be6854bc26cdf1308c466257ba03b0a8cfffd668332454a59311239347f6bd83fb53a742ad85d06b607c45c9f0d1498a53fca9cb82595406f760ce362d3761 SHA512 b0a5b37bd0e9bf09ef742f2b3b4b06d0954a66f411f87975e023468b8705dc31e58bd365cb501a1c53777cf98c05b5473bf12f034a55b8b99066202a382d196d
DIST bison-3.2.1.tar.xz 2091684 BLAKE2B f2cfb1ec96dc0c5daf71a78348c8b4cb212262c00fa7f4474fd5634dd88bfe76b2ff63c9bb047d7b7eb42490bb188c5cb1db8cb1b9caa8972f9771bcbd74acce SHA512 2f6382d276d37f513a4cbb5badd8ac45a7f936e075ccd0d55e5a27802538fd2fdda24b7dc780d006eca0da499b264817a7aa6901bf423666bb34e86d3a180a52
+DIST bison-3.2.2-patches-01.tar.xz 9300 BLAKE2B ce48cd493d6fd5767b76125599c8c603c64ebd16772896cef14fd623386d5e3cf98f184892e7916840d1033c3059f6c175434e6aed304eb1061e316ca073e190 SHA512 54419279dbe3d0080a63e3e3dd862f2046ced266a4cc0b06f545295719210ed07bfed01efc2109a8208689408a103686967bc4e193bffd3de696af4b8350a7e0
+DIST bison-3.2.2.tar.xz 2091244 BLAKE2B 09448b6af67e05a2cc5011eb9de987473cdaa1a9d387baf0df876811ba052682fcf24df06c0d26fe019ce75a194e1f046f0e6f0ab6b895cf28b3d4f75f0c9091 SHA512 b1a49f5c987f1b39febb6b9557d5bafd0ab4952f4e9b9c3ad7650210643ba3bbf365367bf1736f396c1b881b13fff52a69409198fad5a4120c19f29c0fb4e2f1
DIST bison-3.2.tar.xz 2088320 BLAKE2B dacdf492ca49e51d30cd134db763bd174612d3e49531325f524fc1af602ba11068abdc2fac18a3698cf0f24508b6297a437f9d7ab81639869840ca1348f0b012 SHA512 2ca555df9b25f0764698cb152269dc1c24816ffeb6f912c12d1c8d1cf067f73e63c953ab2040b4dd894e6cc46a0d5b2f7cdae0ad8303e40fcd687b42d7d91410
diff --git a/sys-devel/bison/bison-3.2.2.ebuild b/sys-devel/bison/bison-3.2.2.ebuild
new file mode 100644
index 000000000000..c70a4d81f8f3
--- /dev/null
+++ b/sys-devel/bison/bison-3.2.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+PATCHES="${P}-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.1-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${P}-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED%/}"/usr/bin/yacc{,.bison} || die
+ mv "${ED%/}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED%/}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED%/}"/usr/share/${PN}/README "${ED%/}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}