summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/boost-m4')
-rw-r--r--sys-devel/boost-m4/Manifest1
-rw-r--r--sys-devel/boost-m4/boost-m4-0.4_p20160328.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/boost-m4/Manifest b/sys-devel/boost-m4/Manifest
index 1b3f5b98fd2a..733dbe383fa8 100644
--- a/sys-devel/boost-m4/Manifest
+++ b/sys-devel/boost-m4/Manifest
@@ -1 +1,2 @@
DIST boost-m4-0.4.tar.gz 38871 SHA256 abe1fbc30cdd1e938cd5b00cbcbfc370d159404f9014c6dce1976b093cd242e0 SHA512 f0ee9edbf20043679339bcb46a912d460a787635106559780d6a9a08dd685051a58667a0a1e26364709de10dde49f4b2fd348dbd6199a9da3099d75e665c1e95 WHIRLPOOL 8478f8f742004f3ef8ab11bb27c1c2d172fc9060a0ac6041a131f90369af9a8cc6db6ae0e1f108832d5e2c262aba98604b32601a89afecc4be135b7e1b4d18d3
+DIST boost-m4-0.4_p20160328.tar.gz 41253 SHA256 185c6ce9b999d9c3cf64bfff03c2c79cd29e0fe66c0566d8ef8919cfaf2e2dcc SHA512 4aecd311b21ced4a3d62fc706a9fa731c375ea490482f78756892243b5af6909cd8841c249632b37820be7f1bde41c290e842edd933d0c727e1dca76d30eb506 WHIRLPOOL f1e3f6d18c5b11bf3ae27cc05d5af1bc784e794961ac8336e9cf74fd3a2f552efe215631af9b1c82d562f1afa21da009e6ad57191ccf24f9dd005ff15f1f2792
diff --git a/sys-devel/boost-m4/boost-m4-0.4_p20160328.ebuild b/sys-devel/boost-m4/boost-m4-0.4_p20160328.ebuild
new file mode 100644
index 000000000000..22eac3d69b9b
--- /dev/null
+++ b/sys-devel/boost-m4/boost-m4-0.4_p20160328.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Another set of autoconf macros for compiling against boost"
+HOMEPAGE="https://github.com/tsuna/boost.m4"
+SRC_URI="https://dev.gentoo.org/~soap/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+S="${WORKDIR}/boost.m4-1489691f65aecb593e33abc3e56ac482dd67da7b"
+
+# boost.m4 has a buildsystem, but the distributer didn't use make dist
+# so we'd have to eautoreconf to use it. Also, its ./configure script
+# DEPENDs on boost. For installing one file, bootstrapping the
+# buildsystem isn't worth it.
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins build-aux/boost.m4
+
+ dodoc AUTHORS NEWS README THANKS
+}