summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/byfl')
-rw-r--r--sys-devel/byfl/Manifest1
-rw-r--r--sys-devel/byfl/byfl-1.6.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/sys-devel/byfl/Manifest b/sys-devel/byfl/Manifest
index cbcbf504d252..b3401c02eb9d 100644
--- a/sys-devel/byfl/Manifest
+++ b/sys-devel/byfl/Manifest
@@ -1,2 +1 @@
-DIST byfl-1.6-llvm-5.0.1.tar.gz 556083 BLAKE2B fbbd158d0a60674db22a74b30e8410817d7cf6202f34e2ae5906cbed3188661de301cb9b9c6488840b6f0f4e3fcdc121a237decce5ffbb1db9827c6be40f1fe7 SHA512 b63db13d686a7b3c0bf69eae62b3a344c4e9e11c4a5c5da2188091e6037c0e9e5f7fb89c37f1256596c9aaefa8fbcd537ab41f48b27f7f2d1ce4a018a788e36d
DIST byfl-1.6-llvm-6.0.0.tar.gz 556081 BLAKE2B 34e233d29aebc340a0dadfa2ca74b35fe8a8c90e8b7d79ebde0da877a2462144d3a82a5c63633786e177c52e04444cd623dd91db870b654f322ee1becbb1e336 SHA512 3b69eb98247cc4e3398788dfbf450624a918c4de731e1ec1b709a5e6aa0dd29988088827468f0bbf4397563b18aca51350cc947ddcbd2e513b51e1fce17ccc01
diff --git a/sys-devel/byfl/byfl-1.6.ebuild b/sys-devel/byfl/byfl-1.6.ebuild
deleted file mode 100644
index 4d749435eab1..000000000000
--- a/sys-devel/byfl/byfl-1.6.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic llvm
-
-if [ "${PV}" = "9999" ]; then
- LLVM_VERSION="6.0.0"
- LLVM_SLOT=6
- EGIT_REPO_URI="https://github.com/lanl/Byfl.git"
- inherit autotools git-r3
- KEYWORDS=""
-else
- LLVM_VERSION="5.0.1"
- LLVM_SLOT=5
- MY_P="${P}-llvm-${LLVM_VERSION}"
- SRC_URI="https://github.com/lanl/Byfl/releases/download/v${MY_P#${PN}-}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~amd64-linux"
-fi
-
-DESCRIPTION="Compiler-based Application Analysis"
-HOMEPAGE="https://github.com/lanl/Byfl"
-
-SLOT="0"
-LICENSE="BSD"
-IUSE="hdf5 static-libs sqlite"
-
-RDEPEND="
- >=sys-devel/clang-${LLVM_VERSION}:${LLVM_SLOT}
- >=sys-devel/llvm-${LLVM_VERSION}:${LLVM_SLOT}
- sys-devel/binutils:*
- dev-lang/perl:=
- dev-perl/Switch
- hdf5? ( sci-libs/hdf5[cxx] )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- [[ ${PV} = 9999 ]] && eautoreconf
-}
-
-src_configure() {
- append-cxxflags -std=c++11
- use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
- econf H5CXX=$(usex hdf5 h5c++ no)
-}