summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/dev86')
-rw-r--r--sys-devel/dev86/Manifest1
-rw-r--r--sys-devel/dev86/dev86-0.16.19.ebuild77
-rw-r--r--sys-devel/dev86/files/dev86-0.16.19-memmove.patch17
3 files changed, 0 insertions, 95 deletions
diff --git a/sys-devel/dev86/Manifest b/sys-devel/dev86/Manifest
index 1c024ea70236..4b159bf82448 100644
--- a/sys-devel/dev86/Manifest
+++ b/sys-devel/dev86/Manifest
@@ -1,2 +1 @@
-DIST Dev86src-0.16.19.tar.gz 713688 BLAKE2B c62a552be801ff109ee30c403d43586e2601342bd6fe0902d287849a88778338764216663c5302e7401e2b09962e116f2e3569c144846e5fcec87523d69ff206 SHA512 4077f7ac800330eb4658ffaa53dc8cc982792b1dcd7a59625cba4a5dac494117c6bd4ec5307bf02349ad6ae3d0c0903ab2e41123a8df94373e469092fa005cd3
DIST Dev86src-0.16.21.tar.gz 717215 BLAKE2B 977353422937f57d2046f151a53008dcec90f4060d60675dcb81fa58af5f1ed758a1950dcbd211cda57c84b55bf58ffbad28195ff115db50a7a1108d434b8b4e SHA512 6d35dc3c7f9735cf7967cdb2bc0f7bee967ae26667cd8cef56bbdf7d7855ef1d35057db4c0031ff86b9b95d3c8ee44aff408446115b35b6c10cf207a33838016
diff --git a/sys-devel/dev86/dev86-0.16.19.ebuild b/sys-devel/dev86/dev86-0.16.19.ebuild
deleted file mode 100644
index 835423c7e4d1..000000000000
--- a/sys-devel/dev86/dev86-0.16.19.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils multilib
-
-DESCRIPTION="Bruce's C compiler - Simple C compiler to generate 8086 code"
-HOMEPAGE="http://www.debath.co.uk/ https://github.com/lkundrak/dev86"
-SRC_URI="http://www.debath.co.uk/dev86/Dev86src-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="sys-devel/bin86"
-DEPEND="${RDEPEND}
- dev-util/gperf"
-
-STRIP_MASK="/usr/*/bcc/lib*.a /usr/*/i386/libc.a"
-
-src_prepare() {
- # elksemu doesn't compile under amd64
- if use amd64; then
- einfo "Not compiling elksemu on amd64"
- sed -i \
- -e 's,alt-libs elksemu,alt-libs,' \
- -e 's,install-lib install-emu,install-lib,' \
- makefile.in || die
- fi
-
- epatch "${FILESDIR}"/dev86-pic.patch
- epatch "${FILESDIR}"/${PN}-0.16.19-fortify.patch
- epatch "${FILESDIR}"/${PN}-0.16.19-memmove.patch #354351
- sed -i \
- -e "s:-O2 -g:${CFLAGS}:" \
- -e '/INEXE=/s:-s::' \
- makefile.in || die
- sed -i \
- -e "s:/lib/:/$(get_libdir)/:" \
- bcc/bcc.c || die
- sed -i -e '/INSTALL_OPTS=/s:-s::' bin86/Makefile || die
- sed -i -e '/install -m 755 -s/s:-s::' dis88/Makefile || die
-}
-
-src_compile() {
- # Don't mess with CPPFLAGS as they tend to break compilation
- # (bug #343655).
- CPPFLAGS=""
-
- # First `make` is also a config, so set all the path vars here
- emake -j1 \
- DIST="${D}" \
- CC="$(tc-getCC)" \
- LIBDIR="/usr/$(get_libdir)/bcc" \
- INCLDIR="/usr/$(get_libdir)/bcc"
-
- export PATH=${S}/bin:${PATH}
- cd bin
- ln -s ncc bcc
- cd ..
- cd bootblocks
- ln -s ../bcc/version.h .
- emake DIST="${D}"
-}
-
-src_install() {
- emake -j1 install-all DIST="${D}"
- dobin bootblocks/makeboot
- # remove all the stuff supplied by bin86
- cd "${D}"
- rm usr/bin/{as,ld,nm,objdump,size}86 || die
- rm usr/man/man1/{as,ld}86.1 || die
- dodir /usr/share/man
- mv usr/man usr/share/
-}
diff --git a/sys-devel/dev86/files/dev86-0.16.19-memmove.patch b/sys-devel/dev86/files/dev86-0.16.19-memmove.patch
deleted file mode 100644
index 12df3f672624..000000000000
--- a/sys-devel/dev86/files/dev86-0.16.19-memmove.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://bugs.gentoo.org/354351
-
-fix sniped from Debian:
-* Fix "FTBFS: ncc: illegal label": apply patch by dai that replaces strcpy
- by memmove (closes: #591133).
-
---- copt/copt.c
-+++ copt/copt.c
-@@ -174,7 +174,7 @@
- /* Delete leading white spaces */
- for (cp = buf; *cp && isspace(*cp); cp++) ;
- if (cp != buf && *cp)
-- strcpy(buf, cp);
-+ memmove(buf, cp, strlen(cp) + 1);
-
- return(buf);
- }