summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/dwz')
-rw-r--r--sys-devel/dwz/dwz-0.12-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/dwz/dwz-0.12-r1.ebuild b/sys-devel/dwz/dwz-0.12-r1.ebuild
new file mode 100644
index 000000000000..9926eba6d80b
--- /dev/null
+++ b/sys-devel/dwz/dwz-0.12-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+FPKG_HASH="1624afa75b94633e03c6e1bb952fb348"
+
+DESCRIPTION="DWARF optimization and duplicate removal tool"
+HOMEPAGE="https://sourceware.org/git/?p=dwz.git;a=summary"
+SRC_URI="https://src.fedoraproject.org/repo/pkgs/dwz/${P}.tar.bz2/${FPKG_HASH}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/elfutils"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^CFLAGS/d' \
+ Makefile || die "sed failed"
+ tc-export CC
+}