summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/files/4.1.0/gcc-4.1.0-cross-compile.patch40
-rw-r--r--sys-devel/kgcc64/files/gcc-configure-LANG.patch64
-rw-r--r--sys-devel/kgcc64/files/gcc-configure-texinfo.patch16
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.6.ebuild9
-rw-r--r--sys-devel/kgcc64/kgcc64-4.1.2.ebuild5
-rw-r--r--sys-devel/kgcc64/kgcc64-4.2.4.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.3.5.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.4.5.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.4.6.ebuild1
-rw-r--r--sys-devel/kgcc64/kgcc64-4.5.3.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.5.4.ebuild1
-rw-r--r--sys-devel/kgcc64/kgcc64-4.6.4.ebuild1
-rw-r--r--sys-devel/kgcc64/kgcc64-4.7.3.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.7.4.ebuild1
-rw-r--r--sys-devel/kgcc64/kgcc64-4.8.3.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.8.5.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-4.9.4.ebuild3
-rw-r--r--sys-devel/kgcc64/kgcc64-5.4.0.ebuild1
-rw-r--r--sys-devel/kgcc64/kgcc64-6.3.0.ebuild1
19 files changed, 134 insertions, 30 deletions
diff --git a/sys-devel/kgcc64/files/4.1.0/gcc-4.1.0-cross-compile.patch b/sys-devel/kgcc64/files/4.1.0/gcc-4.1.0-cross-compile.patch
new file mode 100644
index 000000000000..523caa48a3c8
--- /dev/null
+++ b/sys-devel/kgcc64/files/4.1.0/gcc-4.1.0-cross-compile.patch
@@ -0,0 +1,40 @@
+Some notes on the 'bootstrap with or without libc headers' debate:
+http://linuxfromscratch.org/pipermail/lfs-dev/2005-July/052409.html
+http://gcc.gnu.org/ml/gcc/2005-07/msg01195.html
+
+--- gcc/unwind-dw2.c
++++ gcc/unwind-dw2.c
+@@ -253,9 +253,11 @@
+ }
+ #endif
+
++#ifndef inhibit_libc
+ #ifdef MD_UNWIND_SUPPORT
+ #include MD_UNWIND_SUPPORT
+ #endif
++#endif
+
+ /* Extract any interesting information from the CIE for the translation
+ unit F belongs to. Return a pointer to the byte after the augmentation,
+--- gcc/configure
++++ gcc/configure
+@@ -12857,7 +12857,7 @@ then
+ | powerpc*-*-*,powerpc64*-*-*)
+ CROSS="$CROSS -DNATIVE_CROSS" ;;
+ esac
+-elif test "x$TARGET_SYSTEM_ROOT" != x; then
++elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
+ SYSTEM_HEADER_DIR=$build_system_header_dir
+ fi
+
+--- gcc/configure.ac
++++ gcc/configure.ac
+@@ -1717,7 +1717,7 @@ then
+ | powerpc*-*-*,powerpc64*-*-*)
+ CROSS="$CROSS -DNATIVE_CROSS" ;;
+ esac
+-elif test "x$TARGET_SYSTEM_ROOT" != x; then
++elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
+ SYSTEM_HEADER_DIR=$build_system_header_dir
+ fi
+
diff --git a/sys-devel/kgcc64/files/gcc-configure-LANG.patch b/sys-devel/kgcc64/files/gcc-configure-LANG.patch
new file mode 100644
index 000000000000..d1b1b0353662
--- /dev/null
+++ b/sys-devel/kgcc64/files/gcc-configure-LANG.patch
@@ -0,0 +1,64 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure
++++ configure
+@@ -54,6 +54,19 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval $as_var=C; export $as_var) 2>&1`"); then
++ eval $as_var=C; export $as_var
++ else
++ unset $as_var
++ fi
++done
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
+@@ -1850,6 +1850,19 @@
+ # Compiler output produced by configure, useful for debugging
+ # configure, is in ./config.log if it exists.
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval \$as_var=C; export \$as_var) 2>&1`"); then
++ eval \$as_var=C; export \$as_var
++ else
++ unset \$as_var
++ fi
++done
++
+ ac_cs_usage="Usage: $CONFIG_STATUS [--recheck] [--version] [--help]"
+ for ac_option
+ do
diff --git a/sys-devel/kgcc64/files/gcc-configure-texinfo.patch b/sys-devel/kgcc64/files/gcc-configure-texinfo.patch
new file mode 100644
index 000000000000..ddc098ddbd58
--- /dev/null
+++ b/sys-devel/kgcc64/files/gcc-configure-texinfo.patch
@@ -0,0 +1,16 @@
+Chances are quite good that the installed makeinfo is sufficient.
+So ignore false positives where the makeinfo installed is so new
+that it violates the cheesy version grep.
+
+http://bugs.gentoo.org/198182
+
+--- configure
++++ configure
+@@ -3573,6 +3573,6 @@
+ :
+ else
+- MAKEINFO="$MISSING makeinfo"
++ :
+ fi
+ ;;
+
diff --git a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
index a11b85f78a5a..efe40943f4e1 100644
--- a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
+++ b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.2"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
@@ -34,7 +33,7 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
src_prepare() {
toolchain_src_prepare
- epatch "${GCC_FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
+ epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
# Arch stuff
case $(tc-arch) in
@@ -42,7 +41,7 @@ src_prepare() {
# Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
# -mtune=r10000 support to gcc (Allows the compiler to generate code to
# take advantage of R10k's second ALU, perform shifts, etc..
- epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
+ epatch "${FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
# This is a very special patch -- it allows us to build kernels on SGI IP28
# (Indigo2 Impact R10000) systems.
@@ -54,7 +53,7 @@ src_prepare() {
# The option also accepts a flag, which are highlighted below:
# -mr10k-cache-barrier=1 - Protect stores only (IP28)
# -mr10k-cache-barrier=2 - Protect stores and loads (IP32 R10K)
- epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
+ epatch "${FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
;;
esac
}
diff --git a/sys-devel/kgcc64/kgcc64-4.1.2.ebuild b/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
index 06a1d5cb051e..1b944aebd722 100644
--- a/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0.1"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
@@ -35,7 +34,7 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
src_prepare() {
toolchain_src_prepare
# Fix cross-compiling
- epatch "${GCC_FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
}
pkg_postinst() {
diff --git a/sys-devel/kgcc64/kgcc64-4.2.4.ebuild b/sys-devel/kgcc64/kgcc64-4.2.4.ebuild
index 507cca65d8db..280b4f0fb815 100644
--- a/sys-devel/kgcc64/kgcc64-4.2.4.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.3.5.ebuild b/sys-devel/kgcc64/kgcc64-4.3.5.ebuild
index dab1a17f7881..d42caa3d104c 100644
--- a/sys-devel/kgcc64/kgcc64-4.3.5.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.3.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.1"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.4.5.ebuild b/sys-devel/kgcc64/kgcc64-4.4.5.ebuild
index 72c0334e2acb..a40dfa3752db 100644
--- a/sys-devel/kgcc64/kgcc64-4.4.5.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.2"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.4.6.ebuild b/sys-devel/kgcc64/kgcc64-4.4.6.ebuild
index 44fb7243b552..4cf0932591db 100644
--- a/sys-devel/kgcc64/kgcc64-4.4.6.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.4.6.ebuild
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.5.3.ebuild b/sys-devel/kgcc64/kgcc64-4.5.3.ebuild
index ae7a058dcac1..4d7b7305dff7 100644
--- a/sys-devel/kgcc64/kgcc64-4.5.3.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.4"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.5.4.ebuild b/sys-devel/kgcc64/kgcc64-4.5.4.ebuild
index 8a98169637fe..f89cae018873 100644
--- a/sys-devel/kgcc64/kgcc64-4.5.4.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.5.4.ebuild
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.2"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.6.4.ebuild b/sys-devel/kgcc64/kgcc64-4.6.4.ebuild
index 5f6fc1d5a612..df9275b16763 100644
--- a/sys-devel/kgcc64/kgcc64-4.6.4.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.6.4.ebuild
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.7.3.ebuild b/sys-devel/kgcc64/kgcc64-4.7.3.ebuild
index 8c72bb1ba7b1..0fb3d04c68e1 100644
--- a/sys-devel/kgcc64/kgcc64-4.7.3.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.7.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.3"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.7.4.ebuild b/sys-devel/kgcc64/kgcc64-4.7.4.ebuild
index 787c3e6b10b9..e126ea64f8d6 100644
--- a/sys-devel/kgcc64/kgcc64-4.7.4.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.7.4.ebuild
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.8.3.ebuild b/sys-devel/kgcc64/kgcc64-4.8.3.ebuild
index 5c2352ce4302..731074eedc19 100644
--- a/sys-devel/kgcc64/kgcc64-4.8.3.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.8.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.1"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.8.5.ebuild b/sys-devel/kgcc64/kgcc64-4.8.5.ebuild
index a5ef49425d75..90d69128a02c 100644
--- a/sys-devel/kgcc64/kgcc64-4.8.5.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.8.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.3"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-4.9.4.ebuild b/sys-devel/kgcc64/kgcc64-4.9.4.ebuild
index 96fab0c3816e..40df19c0457a 100644
--- a/sys-devel/kgcc64/kgcc64-4.9.4.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.9.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-5.4.0.ebuild b/sys-devel/kgcc64/kgcc64-5.4.0.ebuild
index 919b590103c1..40df19c0457a 100644
--- a/sys-devel/kgcc64/kgcc64-5.4.0.ebuild
+++ b/sys-devel/kgcc64/kgcc64-5.4.0.ebuild
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain
diff --git a/sys-devel/kgcc64/kgcc64-6.3.0.ebuild b/sys-devel/kgcc64/kgcc64-6.3.0.ebuild
index e51d7af905e1..12508960bb41 100644
--- a/sys-devel/kgcc64/kgcc64-6.3.0.ebuild
+++ b/sys-devel/kgcc64/kgcc64-6.3.0.ebuild
@@ -16,7 +16,6 @@ TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1.0"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
inherit eutils toolchain