summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/files/libtool-2.4.6-fuse-ld.patch21
-rw-r--r--sys-devel/libtool/libtool-2.4.6-r1.ebuild6
-rw-r--r--sys-devel/libtool/libtool-9999.ebuild6
3 files changed, 32 insertions, 1 deletions
diff --git a/sys-devel/libtool/files/libtool-2.4.6-fuse-ld.patch b/sys-devel/libtool/files/libtool-2.4.6-fuse-ld.patch
index eb8ee07b6c9a..c352d52aac3b 100644
--- a/sys-devel/libtool/files/libtool-2.4.6-fuse-ld.patch
+++ b/sys-devel/libtool/files/libtool-2.4.6-fuse-ld.patch
@@ -29,6 +29,25 @@ index d5cf07a..0fc8279 100644
func_quote_for_eval "$arg"
arg=$func_quote_for_eval_result
func_append compile_command " $arg"
+
+patch the generated file too to keep help2man from generating man pages
+https://bugs.gentoo.org/556512
+
+--- a/build-aux/ltmain.sh
++++ b/build-aux/ltmain.sh
+@@ -5360,10 +5360,12 @@ func_mode_link ()
+ # -tp=* Portland pgcc target processor selection
+ # --sysroot=* for sysroot support
+ # -O*, -g*, -flto*, -fwhopr*, -fuse-linker-plugin GCC link-time optimization
++ # -fuse-ld=* Linker select flags for GCC
+ # -stdlib=* select c++ std lib with clang
+ -64|-mips[0-9]|-r[0-9][0-9]*|-xarch=*|-xtarget=*|+DA*|+DD*|-q*|-m*| \
+ -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \
+- -O*|-g*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*|-stdlib=*)
++ -O*|-g*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*|-stdlib=*| \
++ -fuse-ld=*)
+ func_quote_for_eval "$arg"
+ arg=$func_quote_for_eval_result
+ func_append compile_command " $arg"
--
2.3.2
-
diff --git a/sys-devel/libtool/libtool-2.4.6-r1.ebuild b/sys-devel/libtool/libtool-2.4.6-r1.ebuild
index 5dbc9f92a2a1..677db335de65 100644
--- a/sys-devel/libtool/libtool-2.4.6-r1.ebuild
+++ b/sys-devel/libtool/libtool-2.4.6-r1.ebuild
@@ -53,6 +53,12 @@ src_prepare() {
popd >/dev/null
AT_NOELIBTOOLIZE=yes eautoreconf
epunt_cxx
+
+ # Make sure timestamps don't trigger a rebuild of man pages. #556512
+ if [[ ${PV} != "9999" ]] ; then
+ touch doc/*.1
+ export HELP2MAN=false
+ fi
}
src_configure() {
diff --git a/sys-devel/libtool/libtool-9999.ebuild b/sys-devel/libtool/libtool-9999.ebuild
index 923f8b49ee57..8b6ede52b1cf 100644
--- a/sys-devel/libtool/libtool-9999.ebuild
+++ b/sys-devel/libtool/libtool-9999.ebuild
@@ -50,6 +50,12 @@ src_prepare() {
popd >/dev/null
AT_NOELIBTOOLIZE=yes eautoreconf
epunt_cxx
+
+ # Make sure timestamps don't trigger a rebuild of man pages. #556512
+ if [[ ${PV} != "9999" ]] ; then
+ touch doc/*.1
+ export HELP2MAN=false
+ fi
}
src_configure() {