summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-10.0.1.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-10.0.1.9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-10.0.1.9999.ebuild b/sys-devel/llvm/llvm-10.0.1.9999.ebuild
index 2925a2bdb65c..f6ffe396ea10 100644
--- a/sys-devel/llvm/llvm-10.0.1.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.1.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm.org multilib-minimal multiprocessing \
- pax-utils python-any-r1 toolchain-funcs
+inherit cmake llvm.org multilib-minimal multiprocessing pax-utils \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -195,13 +195,13 @@ src_prepare() {
sed -i -e '/source_parsers/d' docs/conf.py || die
fi
+ # Verify that the live ebuild is up-to-date
+ check_live_ebuild
+
# cmake eclasses suck by forcing ${S} here
CMAKE_USE_DIR=${S} \
S=${WORKDIR} \
- cmake-utils_src_prepare
-
- # Verify that the live ebuild is up-to-date
- check_live_ebuild
+ cmake_src_prepare
}
# Is LLVM being linked against libc++?
@@ -440,13 +440,13 @@ multilib_src_configure() {
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
- cmake-utils_src_configure
+ cmake_src_configure
multilib_is_native_abi && check_distribution_components
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
pax-mark m "${BUILD_DIR}"/bin/lli
@@ -462,7 +462,7 @@ multilib_src_compile() {
multilib_src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check
+ cmake_build check
}
src_install() {
@@ -482,7 +482,7 @@ src_install() {
}
multilib_src_install() {
- DESTDIR=${D} cmake-utils_src_make install-distribution
+ DESTDIR=${D} cmake_build install-distribution
# move headers to /usr/include for wrapping
rm -rf "${ED}"/usr/include || die