summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index 5af65c0f4a0d..e005e516f322 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake llvm.org multilib-minimal multiprocessing pax-utils \
- python-any-r1 toolchain-funcs
+inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
+ toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -70,9 +70,6 @@ RDEPEND="${RDEPEND}
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
if use doc; then
has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" ||
@@ -192,10 +189,7 @@ src_prepare() {
# Verify that the live ebuild is up-to-date
check_live_ebuild
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
+ llvm.org_src_prepare
}
# Is LLVM being linked against libc++?
@@ -395,7 +389,7 @@ multilib_src_configure() {
# fi
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
)
if multilib_is_native_abi; then