summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-3.7.0-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.7.0-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-3.7.0-r2.ebuild b/sys-devel/llvm/llvm-3.7.0-r2.ebuild
index de885b71de67..303ce9872f50 100644
--- a/sys-devel/llvm/llvm-3.7.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.7.0-r2.ebuild
@@ -40,9 +40,10 @@ COMMON_DEPEND="
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
ocaml? (
- dev-lang/ocaml:0=
+ >=dev-lang/ocaml-4.00.0:0=
dev-ml/findlib
- dev-ml/ocaml-ctypes )"
+ dev-ml/ocaml-ctypes
+ !!<=sys-devel/llvm-3.7.0-r2[ocaml] )"
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${COMMON_DEPEND}
dev-lang/perl
@@ -151,6 +152,8 @@ src_prepare() {
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
epatch "${FILESDIR}"/cmake/${P}-ocaml-multilib.patch
+ # Do not build/install ocaml docs with USE=-doc, bug #562008
+ epatch "${FILESDIR}"/cmake/${P}-ocaml-build_doc.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780