summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-3.7.0-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.7.0-r2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-3.7.0-r2.ebuild b/sys-devel/llvm/llvm-3.7.0-r2.ebuild
index c63f3705f197..8856b56b9cbe 100644
--- a/sys-devel/llvm/llvm-3.7.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.7.0-r2.ebuild
@@ -181,6 +181,10 @@ src_prepare() {
epatch "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
epatch "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
+ # Do not force -march flags on arm platforms
+ # https://bugs.gentoo.org/show_bug.cgi?id=562706
+ epatch "${FILESDIR}"/cmake/${P}-compiler_rt_arm_march_flags.patch
+
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)
# https://llvm.org/bugs/show_bug.cgi?id=23793