summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-7.0.0.ebuild4
-rw-r--r--sys-devel/llvm/llvm-7.0.9999.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
-rw-r--r--sys-devel/llvm/metadata.xml2
4 files changed, 11 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-7.0.0.ebuild b/sys-devel/llvm/llvm-7.0.0.ebuild
index 9ce79663c29f..ef47128aa166 100644
--- a/sys-devel/llvm/llvm-7.0.0.ebuild
+++ b/sys-devel/llvm/llvm-7.0.0.ebuild
@@ -33,12 +33,13 @@ LICENSE="UoI-NCSA rc BSD public-domain
llvm_targets_ARM? ( LLVM-Grant )"
SLOT="$(ver_cut 1)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug doc gold libedit +libffi ncurses test xar xml
+IUSE="debug doc exegesis gold libedit +libffi ncurses test xar xml
kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=
+ exegesis? ( dev-libs/libpfm:= )
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
@@ -111,6 +112,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-DLLVM_ENABLE_LIBXML2=$(usex xml)
-DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+ -DLLVM_ENABLE_LIBPFM=$(usex exegesis)
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
diff --git a/sys-devel/llvm/llvm-7.0.9999.ebuild b/sys-devel/llvm/llvm-7.0.9999.ebuild
index 2777a3c503c1..b97e3a6b47bd 100644
--- a/sys-devel/llvm/llvm-7.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-7.0.9999.ebuild
@@ -35,12 +35,13 @@ LICENSE="UoI-NCSA rc BSD public-domain
llvm_targets_ARM? ( LLVM-Grant )"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="debug doc gold libedit +libffi ncurses test xar xml
+IUSE="debug doc exegesis gold libedit +libffi ncurses test xar xml
kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=
+ exegesis? ( dev-libs/libpfm:= )
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
@@ -111,6 +112,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-DLLVM_ENABLE_LIBXML2=$(usex xml)
-DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+ -DLLVM_ENABLE_LIBPFM=$(usex exegesis)
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 196984744a54..014336a4f3eb 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -37,12 +37,13 @@ LICENSE="UoI-NCSA rc BSD public-domain
llvm_targets_ARM? ( LLVM-Grant )"
SLOT="8"
KEYWORDS=""
-IUSE="debug doc gold libedit +libffi ncurses test xar xml
+IUSE="debug doc exegesis gold libedit +libffi ncurses test xar xml
kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=
+ exegesis? ( dev-libs/libpfm:= )
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
@@ -139,6 +140,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-DLLVM_ENABLE_LIBXML2=$(usex xml)
-DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+ -DLLVM_ENABLE_LIBPFM=$(usex exegesis)
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
diff --git a/sys-devel/llvm/metadata.xml b/sys-devel/llvm/metadata.xml
index e35461842711..4538466dde0e 100644
--- a/sys-devel/llvm/metadata.xml
+++ b/sys-devel/llvm/metadata.xml
@@ -14,6 +14,8 @@
<flag name="default-compiler-rt">Use compiler-rt instead of libgcc as the default rtlib for clang</flag>
<flag name="default-libcxx">Use libc++ instead of libstdc++ as the default stdlib for clang</flag>
<flag name="doc">Build and install the HTML documentation and regenerate the man pages</flag>
+ <flag name="exegesis">Enable performance counter support for llvm-exegesis tool
+ that can be used to measure host machine instruction characteristics</flag>
<flag name="gold">Build the gold linker plugin</flag>
<flag name="lldb">Build the lldb debugger</flag>
<flag name="multitarget">Build all host targets (default: host only)</flag>