summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/make/make-4.2.1-r2.ebuild')
-rw-r--r--sys-devel/make/make-4.2.1-r2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sys-devel/make/make-4.2.1-r2.ebuild b/sys-devel/make/make-4.2.1-r2.ebuild
deleted file mode 100644
index c52a434b513b..000000000000
--- a/sys-devel/make/make-4.2.1-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
- "${FILESDIR}"/${PN}-4.2-default-cxx.patch
- "${FILESDIR}"/${PN}-4.2.1-perl526.patch
- "${FILESDIR}"/${PN}-4.2.1-glob-internals.patch
-)
-
-src_prepare() {
- default
- # This patch requires special handling as it modifies configure.ac
- # which in turn triggers maintainer-mode when being applied the
- # usual way.
- eapply -Z "${FILESDIR}"/${PN}-4.2.1-glob-v2.patch
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myeconfargs=(
- --program-prefix=g
- $(use_with guile)
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}