summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20160602.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index d2dba236b799..3c8692ffac6d 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1 +1,2 @@
DIST crossdev-20151026.tar.xz 22160 SHA256 ad5ff1cc334325f83f60f87f9a6d795c606317665042cece9d8f12297312ca28 SHA512 f60efd4ad867efd0eb33de5fe327ccbfe73b574c97507bc0edd7ef141ad74c035ae2a0d446180e6a9eb5f43197f44933a452245feec849bacfb03fc07067edd0 WHIRLPOOL 7a8f556e53e7142ccf9c56d6daf700b33d66e530d85e5a5ed5b154a52bbba450956381af06f7b5748a6a82a43666a8c1b7d879296869dadd090e8887fc623ea9
+DIST crossdev-20160602.tar.xz 22292 SHA256 12dcbbdedc3f89a7b782c2b61c2956da050cfc95eef860a2f2701bfc89c77ce9 SHA512 580cc51e599086a14c51153e656d30b5c2f0e08c7601384d3e082716edeaa532e832b515df2517618cc51be187fcf8738db10e412a5635a16d0bb58b1631a53e WHIRLPOOL 7ccc23cd01030e1b55266784448187ab30ded10b229b03886faf739fd5d1ed07d73c60fb950c1c28c81e7dd309324bd740d8439640113241f493973ba79b53cd
diff --git a/sys-devel/crossdev/crossdev-20160602.ebuild b/sys-devel/crossdev/crossdev-20160602.ebuild
new file mode 100644
index 000000000000..d9e38620c110
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20160602.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}