summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/libtool-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-devel/libtool/libtool-9999.ebuild b/sys-devel/libtool/libtool-9999.ebuild
index 8b6ede52b1cf..e46a9feace7d 100644
--- a/sys-devel/libtool/libtool-9999.ebuild
+++ b/sys-devel/libtool/libtool-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=5
LIBTOOLIZE="true" #225559
WANT_LIBTOOL="none"
@@ -11,7 +11,7 @@ inherit eutils autotools multilib unpacker
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-2
+ inherit git-r3
else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
@@ -24,6 +24,7 @@ LICENSE="GPL-2"
SLOT="2"
IUSE="vanilla"
+# Pull in libltdl directly until we convert packages to the new dep.
RDEPEND="sys-devel/gnuconfig
>=sys-devel/autoconf-2.69
>=sys-devel/automake-1.13"
@@ -33,7 +34,7 @@ DEPEND="${RDEPEND}
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
+ git-r3_src_unpack
cd "${S}"
./bootstrap || die
else