summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf-archive/autoconf-archive-2016.03.20-r1.ebuild (renamed from sys-devel/autoconf-archive/autoconf-archive-2016.03.20.ebuild)10
-rw-r--r--sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-cxxcpp.patch111
-rw-r--r--sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-include.patch54
3 files changed, 172 insertions, 3 deletions
diff --git a/sys-devel/autoconf-archive/autoconf-archive-2016.03.20.ebuild b/sys-devel/autoconf-archive/autoconf-archive-2016.03.20-r1.ebuild
index 05247b092dac..d504d009ae0f 100644
--- a/sys-devel/autoconf-archive/autoconf-archive-2016.03.20.ebuild
+++ b/sys-devel/autoconf-archive/autoconf-archive-2016.03.20-r1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=6
+EAPI="6"
DESCRIPTION="GNU Autoconf Macro Archive"
HOMEPAGE="https://www.gnu.org/software/autoconf-archive/"
@@ -13,11 +12,16 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""
-#file collisions, bug #540246
+# File collisions. #540246
RDEPEND="!=gnome-base/gnome-common-3.14.0
!>=gnome-base/gnome-common-3.14.0-r1[-autoconf-archive(+)]"
DEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${P}-cxxcpp.patch #581346
+ "${FILESDIR}"/${P}-include.patch #581346
+)
+
src_install() {
default
rm -r "${ED}/usr/share/${PN}" || die
diff --git a/sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-cxxcpp.patch b/sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-cxxcpp.patch
new file mode 100644
index 000000000000..c42a655302c1
--- /dev/null
+++ b/sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-cxxcpp.patch
@@ -0,0 +1,111 @@
+https://bugs.gentoo.org/581346
+
+From 34104ea9e635fae5551fd1d6495a80f8041c4adc Mon Sep 17 00:00:00 2001
+From: "Enrico M. Crisostomo" <enrico.m.crisostomo@gmail.com>
+Date: Sun, 20 Mar 2016 14:17:15 +0100
+Subject: [PATCH] Update CXXCPP after updating CXX.
+
+Rewrap text.
+
+Rewrap.
+---
+ m4/ax_cxx_compile_stdcxx.m4 | 14 ++++++++++----
+ m4/ax_cxx_compile_stdcxx_11.m4 | 5 +++--
+ m4/ax_cxx_compile_stdcxx_14.m4 | 5 +++--
+ 3 files changed, 16 insertions(+), 8 deletions(-)
+
+diff --git a/m4/ax_cxx_compile_stdcxx.m4 b/m4/ax_cxx_compile_stdcxx.m4
+index 8adc765..2c18e49 100644
+--- a/m4/ax_cxx_compile_stdcxx.m4
++++ b/m4/ax_cxx_compile_stdcxx.m4
+@@ -9,9 +9,9 @@
+ # DESCRIPTION
+ #
+ # Check for baseline language coverage in the compiler for the specified
+-# version of the C++ standard. If necessary, add switches to CXX to
+-# enable support. VERSION may be '11' (for the C++11 standard) or '14'
+-# (for the C++14 standard).
++# version of the C++ standard. If necessary, add switches to CXX and
++# CXXCPP to enable support. VERSION may be '11' (for the C++11 standard)
++# or '14' (for the C++14 standard).
+ #
+ # The second argument, if specified, indicates whether you insist on an
+ # extended mode (e.g. -std=gnu++11) or a strict conformance mode (e.g.
+@@ -39,7 +39,7 @@
+ # and this notice are preserved. This file is offered as-is, without any
+ # warranty.
+
+-#serial 3
++#serial 4
+
+ dnl This macro is based on the code from the AX_CXX_COMPILE_STDCXX_11 macro
+ dnl (serial version number 13).
+@@ -82,6 +82,9 @@ AC_DEFUN([AX_CXX_COMPILE_STDCXX], [dnl
+ CXX="$ac_save_CXX"])
+ if eval test x\$$cachevar = xyes; then
+ CXX="$CXX $switch"
++ if test -n "$CXXCPP" ; then
++ CXXCPP="$CXXCPP $switch"
++ fi
+ ac_success=yes
+ break
+ fi
+@@ -105,6 +108,9 @@ AC_DEFUN([AX_CXX_COMPILE_STDCXX], [dnl
+ CXX="$ac_save_CXX"])
+ if eval test x\$$cachevar = xyes; then
+ CXX="$CXX $switch"
++ if test -n "$CXXCPP" ; then
++ CXXCPP="$CXXCPP $switch"
++ fi
+ ac_success=yes
+ break
+ fi
+diff --git a/m4/ax_cxx_compile_stdcxx_11.m4 b/m4/ax_cxx_compile_stdcxx_11.m4
+index b3d4bfd..3dd5cf9 100644
+--- a/m4/ax_cxx_compile_stdcxx_11.m4
++++ b/m4/ax_cxx_compile_stdcxx_11.m4
+@@ -9,7 +9,8 @@
+ # DESCRIPTION
+ #
+ # Check for baseline language coverage in the compiler for the C++11
+-# standard; if necessary, add switches to CXX to enable support.
++# standard; if necessary, add switches to CXX and CXXCPP to enable
++# support.
+ #
+ # This macro is a convenience alias for calling the AX_CXX_COMPILE_STDCXX
+ # macro with the version set to C++11. The two optional arguments are
+@@ -32,7 +33,7 @@
+ # and this notice are preserved. This file is offered as-is, without any
+ # warranty.
+
+-#serial 15
++#serial 16
+
+ include([ax_cxx_compile_stdcxx.m4])
+
+diff --git a/m4/ax_cxx_compile_stdcxx_14.m4 b/m4/ax_cxx_compile_stdcxx_14.m4
+index 741accf..6d2123a 100644
+--- a/m4/ax_cxx_compile_stdcxx_14.m4
++++ b/m4/ax_cxx_compile_stdcxx_14.m4
+@@ -9,7 +9,8 @@
+ # DESCRIPTION
+ #
+ # Check for baseline language coverage in the compiler for the C++14
+-# standard; if necessary, add switches to CXX to enable support.
++# standard; if necessary, add switches to CXX and CXXCPP to enable
++# support.
+ #
+ # This macro is a convenience alias for calling the AX_CXX_COMPILE_STDCXX
+ # macro with the version set to C++14. The two optional arguments are
+@@ -27,7 +28,7 @@
+ # and this notice are preserved. This file is offered as-is, without any
+ # warranty.
+
+-#serial 2
++#serial 3
+
+ include([ax_cxx_compile_stdcxx.m4])
+
+--
+2.8.2
+
diff --git a/sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-include.patch b/sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-include.patch
new file mode 100644
index 000000000000..4ba295ea1845
--- /dev/null
+++ b/sys-devel/autoconf-archive/files/autoconf-archive-2016.03.20-include.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/581346
+
+From d343892fbd0605a9375ff1ae0467aa320a404b12 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 7 May 2016 19:41:40 -0400
+Subject: [PATCH] fix include errors w/AX_CXX_COMPILE_STDCXX_1[14]
+
+The search path for `include` is the current working directory, so trying
+to include other m4 files directly only works if they live in the same dir
+as where you're running `aclocal`. Otherwise we end up with errors like:
+ $ cd lcd4linux-0.10.1-RC2
+ $ aclocal
+ /usr/share/aclocal/ax_cxx_compile_stdcxx_14.m4:32: file 'ax_cxx_compile_stdcxx.m4' does not exist
+
+Use the AX_REQUIRE_DEFINED macro instead to make sure the macro we want
+exists.
+---
+ m4/ax_cxx_compile_stdcxx_11.m4 | 5 ++---
+ m4/ax_cxx_compile_stdcxx_14.m4 | 5 ++---
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/m4/ax_cxx_compile_stdcxx_11.m4 b/m4/ax_cxx_compile_stdcxx_11.m4
+index 3dd5cf9..0aadeaf 100644
+--- a/m4/ax_cxx_compile_stdcxx_11.m4
++++ b/m4/ax_cxx_compile_stdcxx_11.m4
+@@ -33,8 +33,7 @@
+ # and this notice are preserved. This file is offered as-is, without any
+ # warranty.
+
+-#serial 16
+-
+-include([ax_cxx_compile_stdcxx.m4])
++#serial 17
+
++AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX])
+ AC_DEFUN([AX_CXX_COMPILE_STDCXX_11], [AX_CXX_COMPILE_STDCXX([11], [$1], [$2])])
+diff --git a/m4/ax_cxx_compile_stdcxx_14.m4 b/m4/ax_cxx_compile_stdcxx_14.m4
+index 6d2123a..51123f2 100644
+--- a/m4/ax_cxx_compile_stdcxx_14.m4
++++ b/m4/ax_cxx_compile_stdcxx_14.m4
+@@ -28,8 +28,7 @@
+ # and this notice are preserved. This file is offered as-is, without any
+ # warranty.
+
+-#serial 3
+-
+-include([ax_cxx_compile_stdcxx.m4])
++#serial 4
+
++AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX])
+ AC_DEFUN([AX_CXX_COMPILE_STDCXX_14], [AX_CXX_COMPILE_STDCXX([14], [$1], [$2])])
+--
+2.8.2
+