summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/qconf/qconf-2.3.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/sys-devel/qconf/qconf-2.3.ebuild b/sys-devel/qconf/qconf-2.3.ebuild
index 11d8d88cd3f0..bbb151d738c6 100644
--- a/sys-devel/qconf/qconf-2.3.ebuild
+++ b/sys-devel/qconf/qconf-2.3.ebuild
@@ -12,32 +12,25 @@ SRC_URI="http://psi-im.org/files/qconf/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="qt4 +qt5"
+IUSE=""
# There is no one to one match to autotools-based configure
QA_CONFIGURE_OPTIONS=".*"
RDEPEND="
- qt4? ( dev-qt/qtcore:4 )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtxml:5
- )
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
"
DEPEND="${RDEPEND}"
-REQUIRED_USE="^^ ( qt4 qt5 )"
-
src_configure() {
- use qt4 && QTVERSION=4
- use qt5 && QTVERSION=5
econf \
- --qtselect="${QTVERSION}" \
+ --qtselect="5" \
--extraconf=QMAKE_STRIP= \
--verbose || die
# just to set all the Gentoo toolchain flags
- eqmake${QTVERSION}
+ eqmake5
}
src_install() {