summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/m4/Manifest1
-rw-r--r--sys-devel/m4/m4-1.4.17.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/sys-devel/m4/Manifest b/sys-devel/m4/Manifest
index 0a19e0f311dc..b703cf937046 100644
--- a/sys-devel/m4/Manifest
+++ b/sys-devel/m4/Manifest
@@ -1,2 +1 @@
-DIST m4-1.4.17.tar.xz 1149088 BLAKE2B ccba6a1cd80de241bc2e755addbf4876b00ab776e0a3c85691998e3e84e8a091d57d8c3e9b43a115e52e416450de791662a54ca8e64e1603a166029164f140ce SHA512 406e6e97c3f5c5f3c8055bac748d4fe8c2e861d97e84ab6d840a2caa7df04f523cc662d6d51f6afae7d6c219d03693c7ae0c1e669a80246a3ceb5e8342b82389
DIST m4-1.4.18.tar.xz 1207688 BLAKE2B debfaa4d25af6f583e2cd703e77b73775790f48f34e878eddd820c6b244a065c69495473ce5067be1f20ca07b2d6af9f90cffd33e12c18fd719c0d234eb5462a SHA512 06f583efc3855cd8477d8347544f4ae5153a3e50aea74d21968afa7214784ea3ddfc02d0a2b11324120d76a19f2e804d20de11a456b5da929eb6ae469519b174
diff --git a/sys-devel/m4/m4-1.4.17.ebuild b/sys-devel/m4/m4-1.4.17.ebuild
deleted file mode 100644
index 631fdde89ffc..000000000000
--- a/sys-devel/m4/m4-1.4.17.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils
-
-DESCRIPTION="GNU macro processor"
-HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-
-# remember: cannot dep on autoconf since it needs us
-DEPEND="app-arch/xz-utils"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-posix_spawn.patch #580688, 581086
-
- # Disable gnulib build test that has no impact on the source.
- # Re-enable w/next version bump (and gnulib is updated). #554728
- [[ ${PV} != "1.4.17" ]] && die "re-enable test #554728"
- echo 'exit 0' > tests/test-update-copyright.sh || die
-}
-
-src_configure() {
- # Disable automagic dependency over libsigsegv; see bug #278026
- export ac_cv_libsigsegv=no
-
- local myconf=""
- [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
- econf --enable-changeword ${myconf}
-}
-
-src_test() {
- [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
- emake check
-}
-
-src_install() {
- default
- # autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
- # gm4, it might find gm4 from outside the prefix on for instance Darwin
- use prefix && dosym m4 /usr/bin/gm4
- if use examples ; then
- docinto examples
- dodoc examples/*
- rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*
- fi
-}